almost forgot to move dnsmasq.conf
authorMike Baker <mbm@openwrt.org>
Sun, 17 Jul 2005 06:16:27 +0000 (06:16 +0000)
committerMike Baker <mbm@openwrt.org>
Sun, 17 Jul 2005 06:16:27 +0000 (06:16 +0000)
SVN-Revision: 1481

openwrt/package/dnsmasq/Makefile
openwrt/package/dnsmasq/files/dnsmasq.conf [new file with mode: 0644]
openwrt/target/default/target_skeleton/etc/dnsmasq.conf [deleted file]

index ddc27c647265f91c3fb3753366de01b02c84b768..7791f81b6209456701a8c64951d0bfe0a01773f7 100644 (file)
@@ -29,7 +29,7 @@ $(IPKG_DNSMASQ):
        install -d -m0755 $(IDIR_DNSMASQ)/usr/sbin
        cp $(PKG_BUILD_DIR)/src/$(PKG_NAME) $(IDIR_DNSMASQ)/usr/sbin/
        $(STRIP) $(IDIR_DNSMASQ)/usr/sbin/*
-       install -d -m0755 $(IDIR_DNSMASQ)/etc/init.d
+       install -m0644 ./files/dnsmasq.conf $(IDIR_DNSMASQ)/etc
        install -m0755 ./files/S50dnsmasq $(IDIR_DNSMASQ)/etc/init.d
        $(IPKG_BUILD) $(IDIR_DNSMASQ) $(PACKAGE_DIR)
 
diff --git a/openwrt/package/dnsmasq/files/dnsmasq.conf b/openwrt/package/dnsmasq/files/dnsmasq.conf
new file mode 100644 (file)
index 0000000..4ef9680
--- /dev/null
@@ -0,0 +1,25 @@
+# filter what we send upstream
+domain-needed
+bogus-priv
+filterwin2k
+localise-queries
+
+# allow /etc/hosts and dhcp lookups via *.lan
+local=/lan/
+domain=lan
+
+# no dhcp / dns queries from the wan
+except-interface=vlan1
+
+# enable dhcp (start,end,netmask,leasetime)
+dhcp-authoritative
+#dhcp-range=192.168.1.100,192.168.1.250,255.255.255.0,12h
+#dhcp-leasefile=/tmp/dhcp.leases
+
+# use /etc/ethers for static hosts; same format as --dhcp-host
+# <hwaddr> [<hostname>] <ipaddr>
+read-ethers
+
+# other useful options:
+# default route(s): dhcp-option=3,192.168.1.1,192.168.1.2
+#    dns server(s): dhcp-option=6,192.168.1.1,192.168.1.2
diff --git a/openwrt/target/default/target_skeleton/etc/dnsmasq.conf b/openwrt/target/default/target_skeleton/etc/dnsmasq.conf
deleted file mode 100644 (file)
index 4ef9680..0000000
+++ /dev/null
@@ -1,25 +0,0 @@
-# filter what we send upstream
-domain-needed
-bogus-priv
-filterwin2k
-localise-queries
-
-# allow /etc/hosts and dhcp lookups via *.lan
-local=/lan/
-domain=lan
-
-# no dhcp / dns queries from the wan
-except-interface=vlan1
-
-# enable dhcp (start,end,netmask,leasetime)
-dhcp-authoritative
-#dhcp-range=192.168.1.100,192.168.1.250,255.255.255.0,12h
-#dhcp-leasefile=/tmp/dhcp.leases
-
-# use /etc/ethers for static hosts; same format as --dhcp-host
-# <hwaddr> [<hostname>] <ipaddr>
-read-ethers
-
-# other useful options:
-# default route(s): dhcp-option=3,192.168.1.1,192.168.1.2
-#    dns server(s): dhcp-option=6,192.168.1.1,192.168.1.2