[packages/openssh] update openssh to 6.0p1
authorPeter Wagner <​tripolar@gmx.at>
Thu, 26 Apr 2012 12:31:34 +0000 (12:31 +0000)
committerPeter Wagner <​tripolar@gmx.at>
Thu, 26 Apr 2012 12:31:34 +0000 (12:31 +0000)
SVN-Revision: 31482

net/openssh/Makefile
net/openssh/patches/110-no_ripemd_fix.patch
net/openssh/patches/200-dscp-qos.patch

index 3f4bc37168f6ac5ef2435d72a4a109e5b4f32095..6e7c866a4626e641a284ad8c207a7924f6451b6c 100644 (file)
@@ -8,15 +8,15 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=openssh
-PKG_VERSION:=5.9p1
-PKG_RELEASE:=4
+PKG_VERSION:=6.0p1
+PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=ftp://ftp.openbsd.org/pub/OpenBSD/OpenSSH/portable/ \
                ftp://openbsd.wiretapped.net/pub/OpenBSD/OpenSSH/portable/ \
                ftp://ftp.belnet.be/packages/openbsd/OpenSSH/portable/ \
                ftp://ftp.de.openbsd.org/pub/unix/OpenBSD/OpenSSH/portable/
-PKG_MD5SUM:=afe17eee7e98d3b8550cc349834a85d0
+PKG_MD5SUM:=3c9347aa67862881c5da3f3b1c08da7b
 
 PKG_BUILD_DEPENDS:=libopenssl
 
index 35bd0ba93e7c68c4de8406046528bca12db81382..463a9a6cb674215c96abda2670abcf772a059e92 100644 (file)
@@ -1,7 +1,7 @@
 --- a/mac.c
 +++ b/mac.c
-@@ -59,8 +59,10 @@ struct {
-       { "hmac-sha1-96",               SSH_EVP, EVP_sha1, 96, -1, -1 },
+@@ -67,8 +67,10 @@ struct {
+ #endif
        { "hmac-md5",                   SSH_EVP, EVP_md5, 0, -1, -1 },
        { "hmac-md5-96",                SSH_EVP, EVP_md5, 96, -1, -1 },
 +#ifndef OPENSSL_NO_RIPEMD
index 5a728dd19a82f20110c4341352fea58019e1252e..525bbc7e35d10cb979cb6e9f1fdf941ebc0b7fd5 100644 (file)
@@ -1,26 +1,21 @@
-Index: packages/net/openssh/patches/200-enable_dscp_qos.patch
-===================================================================
---- packages/net/openssh/patches/200-enable_dscp_qos.patch     (revision 0)
-+++ packages/net/openssh/patches/200-enable_dscp_qos.patch     (revision 0)
-@@ -0,0 +1,21 @@
-+--- a/ssh_config      2010-01-12 01:40:27.000000000 -0700
-++++ b/ssh_config      2011-02-09 14:35:30.000000000 -0700
-+@@ -45,3 +45,6 @@
-+ #   PermitLocalCommand no
-+ #   VisualHostKey no
-+ #   ProxyCommand ssh -q -W %h:%p gateway.example.com
-++
-++# enable DSCP QoS values (per RFC-4594)
-++#IPQoS AF21 AF11
-+--- a/sshd_config     2010-09-09 19:20:12.000000000 -0600
-++++ b/sshd_config     2011-02-09 14:32:25.000000000 -0700
-+@@ -108,6 +108,9 @@
-+ # no default banner path
-+ #Banner none
-+ 
-++# enable DSCP QoS values (per RFC-4594)
-++#IPQoS AF21 AF11
-++
-+ # override default of no subsystems
-+ Subsystem    sftp    /usr/libexec/sftp-server
-+ 
+--- a/ssh_config       2010-01-12 01:40:27.000000000 -0700
++++ b/ssh_config       2011-02-09 14:35:30.000000000 -0700
+@@ -45,3 +45,6 @@
+ #   PermitLocalCommand no
+ #   VisualHostKey no
+ #   ProxyCommand ssh -q -W %h:%p gateway.example.com
++
++# enable DSCP QoS values (per RFC-4594)
++#IPQoS AF21 AF11
+--- a/sshd_config      2010-09-09 19:20:12.000000000 -0600
++++ b/sshd_config      2011-02-09 14:32:25.000000000 -0700
+@@ -108,6 +108,9 @@
+ # no default banner path
+ #Banner none
++# enable DSCP QoS values (per RFC-4594)
++#IPQoS AF21 AF11
++
+ # override default of no subsystems
+ Subsystem     sftp    /usr/libexec/sftp-server