Merge pull request #5410 from jefferyto/python-pyasn1-0.4.2
authorHannu Nyman <hannu.nyman@iki.fi>
Wed, 10 Jan 2018 16:22:36 +0000 (18:22 +0200)
committerGitHub <noreply@github.com>
Wed, 10 Jan 2018 16:22:36 +0000 (18:22 +0200)
python-pyasn1: update to 0.4.2

12 files changed:
lang/python/python-attrs/Makefile
lang/python/python-cryptography/Makefile
lang/python/python-cryptography/patches/001-disable-setup-requirements.patch
lang/python/python-cryptography/patches/002-remove-undefined-dtls-methods.patch
lang/python/python-gmpy2/Makefile
lang/python/python-ipaddress/Makefile
lang/python/python-parsley/Makefile
lang/python/python-parsley/patches/001-omit-tests.patch [deleted file]
lang/python/python-parsley/patches/001-py3-read-utf8.patch [new file with mode: 0644]
lang/python/python-parsley/patches/002-omit-tests.patch [new file with mode: 0644]
net/openvswitch/Makefile
net/usbip/Makefile

index 21f5b0b54d1d79eaf3f72ded2cf6de448fc3cb17..9c3e6886cf13ee0dc43015358efbbdfa95bf7e34 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2016 OpenWrt.org
+# Copyright (C) 2016-2018 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -7,13 +7,15 @@
 
 include $(TOPDIR)/rules.mk
 
-PKG_NAME:=attrs
-PKG_VERSION:=16.2.0
+PKG_NAME:=python-attrs
+PKG_VERSION:=17.4.0
 PKG_RELEASE:=1
 
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=https://pypi.python.org/packages/6b/71/1682316894ed80b362b9102e7a10997136d8dc1213c36a9f0515c451373a
-PKG_HASH:=136f2ec0f94ec77ff2990830feee965d608cab1e8922370e3abdded383d52001
+PKG_SOURCE:=attrs-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=https://pypi.python.org/packages/8b/0b/a06cfcb69d0cb004fde8bc6f0fd192d96d565d1b8aa2829f0f20adb796e5
+PKG_HASH:=1c7960ccfd6a005cd9f7ba884e6316b5e430a3f1a6c37c5f87d8b43f83b54ec9
+
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(BUILD_VARIANT)-attrs-$(PKG_VERSION)
 
 PKG_LICENSE:=MIT
 PKG_LICENSE_FILES:=LICENSE
@@ -21,14 +23,29 @@ PKG_MAINTAINER:=Jeffery To <jeffery.to@gmail.com>
 
 include $(INCLUDE_DIR)/package.mk
 $(call include_mk, python-package.mk)
+$(call include_mk, python3-package.mk)
+
+PKG_UNPACK:=$(HOST_TAR) -C $(PKG_BUILD_DIR) --strip-components=1 -xzf $(DL_DIR)/$(PKG_SOURCE)
+
+define Package/python-attrs/Default
+  SECTION:=lang
+  CATEGORY:=Languages
+  SUBMENU:=Python
+  URL:=https://attrs.readthedocs.org/
+endef
 
 define Package/python-attrs
-       SECTION:=lang
-       CATEGORY:=Languages
-       SUBMENU:=Python
-       TITLE:=python-attrs
-       URL:=https://attrs.readthedocs.org/
-       DEPENDS:=+python-light
+$(call Package/python-attrs/Default)
+  TITLE:=python-attrs
+  DEPENDS:=+PACKAGE_python-attrs:python-light
+  VARIANT:=python
+endef
+
+define Package/python3-attrs
+$(call Package/python-attrs/Default)
+  TITLE:=python3-attrs
+  DEPENDS:=+PACKAGE_python3-attrs:python3-light
+  VARIANT:=python3
 endef
 
 define Package/python-attrs/description
@@ -37,9 +54,14 @@ the chores of implementing the most common attribute-related object
 protocols.
 endef
 
-define Build/Compile
-       $(call Build/Compile/PyMod,,install --prefix="/usr" --root="$(PKG_INSTALL_DIR)")
+define Package/python3-attrs/description
+$(call Package/python-attrs/description)
+.
+(Variant for Python3)
 endef
 
 $(eval $(call PyPackage,python-attrs))
 $(eval $(call BuildPackage,python-attrs))
+
+$(eval $(call Py3Package,python3-attrs))
+$(eval $(call BuildPackage,python3-attrs))
index fdabd483e7c77e88b640b3b270606a4c2b76d331..acae27fe7ff5f9680a7981f604df1d2444c893c6 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2015-2016 OpenWrt.org
+# Copyright (C) 2015-2018 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,12 +8,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=python-cryptography
-PKG_VERSION:=2.1.3
+PKG_VERSION:=2.1.4
 PKG_RELEASE:=1
 
 PKG_SOURCE:=cryptography-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=https://pypi.python.org/packages/f3/7c/ec4f94489719803cb14d35e9625d1f5a613b9c4b8d01ee52a4c77485e681
-PKG_HASH:=68a26c353627163d74ee769d4749f2ee243866e9dac43c93bb33ebd8fbed1199
+PKG_SOURCE_URL:=https://pypi.python.org/packages/78/c5/7188f15a92413096c93053d5304718e1f6ba88b818357d05d19250ebff85
+PKG_HASH:=e4d967371c5b6b2e67855066471d844c5d52d210c36c28d49a8507b96e2c5291
 
 PKG_LICENSE:=Apache-2.0 BSD-3-Clause
 PKG_LICENSE_FILES:=LICENSE.APACHE LICENSE.BSD
index 07ae483c2efe312cfe303378cbe2d1f4112bf816..65781af52708ac5264767a2a65dac0b863303dfb 100644 (file)
@@ -1,8 +1,6 @@
-diff --git a/setup.py b/setup.py
-index b5c05df..a777dd7 100644
 --- a/setup.py
 +++ b/setup.py
-@@ -266,6 +266,7 @@ class DummyPyTest(test):
+@@ -235,6 +235,7 @@ class DummyPyTest(test):
  with open(os.path.join(base_dir, "README.rst")) as f:
      long_description = f.read()
  
index 3b7aaf3967567b5fa370060de8efde4dfd4bd99c..25ad27d7c9f4ed55142bd884cffaacc0074b80b8 100644 (file)
@@ -1,8 +1,6 @@
-diff --git a/src/_cffi_src/openssl/ssl.py b/src/_cffi_src/openssl/ssl.py
-index 8bda4e0..aa81060 100644
 --- a/src/_cffi_src/openssl/ssl.py
 +++ b/src/_cffi_src/openssl/ssl.py
-@@ -595,9 +595,6 @@ static const long TLS_ST_OK = 0;
+@@ -597,9 +597,6 @@ static const long TLS_ST_OK = 0;
  
  #if defined(OPENSSL_NO_DTLS) || CRYPTOGRAPHY_OPENSSL_LESS_THAN_102
  static const long Cryptography_HAS_GENERIC_DTLS_METHOD = 0;
index e3d01604050390393e9b230130f00b6c4899ff94..b517c87832928804afb1f45b4ee6f51ca47bcb50 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2015-2016 OpenWrt.org
+# Copyright (C) 2015-2018 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -7,28 +7,45 @@
 
 include $(TOPDIR)/rules.mk
 
-PKG_NAME:=gmpy2
+PKG_NAME:=python-gmpy2
 PKG_VERSION:=2.0.8
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).zip
+PKG_SOURCE:=gmpy2-$(PKG_VERSION).zip
 PKG_SOURCE_URL:=https://pypi.python.org/packages/90/f4/9a2e384b325b69bc5827b9a6510a8fb4a51698c915c06a3f25a86458892a
 PKG_HASH:=dd233e3288b90f21b0bb384bcc7a7e73557bb112ccf0032ad52aa614eb373d3f
 
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(BUILD_VARIANT)-gmpy2-$(PKG_VERSION)
+
 PKG_LICENSE:=LGPL-3.0+
 PKG_LICENSE_FILES:=COPYING.LESSER
 PKG_MAINTAINER:=Jeffery To <jeffery.to@gmail.com>
 
 include $(INCLUDE_DIR)/package.mk
 $(call include_mk, python-package.mk)
+$(call include_mk, python3-package.mk)
+
+PKG_UNPACK:=unzip -q -d $(PKG_BUILD_DIR) $(DL_DIR)/$(PKG_SOURCE); mv -f $(PKG_BUILD_DIR)/gmpy2-$(PKG_VERSION)/* $(PKG_BUILD_DIR)
+
+define Package/python-gmpy2/Default
+  SECTION:=lang
+  CATEGORY:=Languages
+  SUBMENU:=Python
+  URL:=http://code.google.com/p/gmpy/
+endef
 
 define Package/python-gmpy2
-       SECTION:=lang
-       CATEGORY:=Languages
-       SUBMENU:=Python
-       TITLE:=python-gmpy2
-       URL:=http://code.google.com/p/gmpy/
-       DEPENDS:=+libgmp +python-light
+$(call Package/python-gmpy2/Default)
+  TITLE:=python-gmpy2
+  DEPENDS:=+libgmp +PACKAGE_python-gmpy2:python-light
+  VARIANT:=python
+endef
+
+define Package/python3-gmpy2
+$(call Package/python-gmpy2/Default)
+  TITLE:=python3-gmpy2
+  DEPENDS:=+libgmp +PACKAGE_python3-gmpy2:python3-light
+  VARIANT:=python3
 endef
 
 define Package/python-gmpy2/description
@@ -41,9 +58,22 @@ API and naming conventions to be more consistent and support the additional
 functionality.
 endef
 
-define Build/Compile
+define Package/python3-gmpy2/description
+$(call Package/python-gmpy2/description)
+.
+(Variant for Python3)
+endef
+
+define PyBuild/Compile
        $(call Build/Compile/PyMod,,install --prefix="/usr" --root="$(PKG_INSTALL_DIR)" --nompfr)
 endef
 
+define Py3Build/Compile
+       $(call Build/Compile/Py3Mod,,install --prefix="/usr" --root="$(PKG_INSTALL_DIR)" --nompfr)
+endef
+
 $(eval $(call PyPackage,python-gmpy2))
 $(eval $(call BuildPackage,python-gmpy2))
+
+$(eval $(call Py3Package,python3-gmpy2))
+$(eval $(call BuildPackage,python3-gmpy2))
index a78e2e8c858b886a60929955a4905b0666d362e6..d4fecf7726dc6ae47e4d5e337ab4af5784acda89 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2015-2016 OpenWrt.org
+# Copyright (C) 2015-2018 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,12 +8,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=ipaddress
-PKG_VERSION:=1.0.17
+PKG_VERSION:=1.0.19
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=https://pypi.python.org/packages/bb/26/3b64955ff73f9e3155079b9ed31812afdfa5333b5c76387454d651ef593a
-PKG_HASH:=3a21c5a15f433710aaa26f1ae174b615973a25182006ae7f9c26de151cd51716
+PKG_SOURCE_URL:=https://pypi.python.org/packages/f0/ba/860a4a3e283456d6b7e2ab39ce5cf11a3490ee1a363652ac50abf9f0f5df
+PKG_HASH:=200d8686011d470b5e4de207d803445deee427455cd0cb7c982b68cf82524f81
 
 PKG_LICENSE:=Python-2.0
 PKG_MAINTAINER:=Jeffery To <jeffery.to@gmail.com>
index c9d604b520ac129bfdc260009d4b0eeca770133b..11e231ab0aab7e22b88df2c00d5826b1bee32a30 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2015 OpenWrt.org
+# Copyright (C) 2015, 2017-2018 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -7,37 +7,67 @@
 
 include $(TOPDIR)/rules.mk
 
-PKG_NAME:=Parsley
+PKG_NAME:=python-parsley
 PKG_VERSION:=1.3
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE:=Parsley-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=https://pypi.python.org/packages/source/P/Parsley
 PKG_HASH:=9444278d47161d5f2be76a767809a3cbe6db4db822f46a4fd7481d4057208d41
 
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(BUILD_VARIANT)-parsley-$(PKG_VERSION)
+
 PKG_LICENSE:=MIT
 PKG_LICENSE_FILES:=LICENSE
 PKG_MAINTAINER:=Jeffery To <jeffery.to@gmail.com>
 
 include $(INCLUDE_DIR)/package.mk
 $(call include_mk, python-package.mk)
+$(call include_mk, python3-package.mk)
+
+PKG_UNPACK:=$(HOST_TAR) -C $(PKG_BUILD_DIR) --strip-components=1 -xzf $(DL_DIR)/$(PKG_SOURCE)
+
+define Package/python-parsley/Default
+  SECTION:=lang
+  CATEGORY:=Languages
+  SUBMENU:=Python
+  URL:=http://launchpad.net/parsley
+endef
 
 define Package/python-parsley
-       SECTION:=lang
-       CATEGORY:=Languages
-       SUBMENU:=Python
-       TITLE:=python-parsley
-       URL:=http://launchpad.net/parsley
-       DEPENDS:=+python-light
+$(call Package/python-parsley/Default)
+  TITLE:=python-parsley
+  DEPENDS:=+PACKAGE_python-parsley:python-light
+  VARIANT:=python
+endef
+
+define Package/python3-parsley
+$(call Package/python-parsley/Default)
+  TITLE:=python3-parsley
+  DEPENDS:=+PACKAGE_python3-parsley:python3-light
+  VARIANT:=python3
 endef
 
 define Package/python-parsley/description
 Parsing and pattern matching made easy.
 endef
 
-define Build/Compile
+define Package/python3-parsley/description
+$(call Package/python-parsley/description)
+.
+(Variant for Python3)
+endef
+
+define PyBuild/Compile
        $(call Build/Compile/PyMod,,install --prefix="/usr" --root="$(PKG_INSTALL_DIR)")
 endef
 
+define Py3Build/Compile
+       $(call Build/Compile/Py3Mod,,install --prefix="/usr" --root="$(PKG_INSTALL_DIR)")
+endef
+
 $(eval $(call PyPackage,python-parsley))
 $(eval $(call BuildPackage,python-parsley))
+
+$(eval $(call Py3Package,python3-parsley))
+$(eval $(call BuildPackage,python3-parsley))
diff --git a/lang/python/python-parsley/patches/001-omit-tests.patch b/lang/python/python-parsley/patches/001-omit-tests.patch
deleted file mode 100644 (file)
index 71bd021..0000000
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -Nur a/setup.py b/setup.py
---- a/setup.py 2015-09-09 10:45:25.000000000 +0800
-+++ b/setup.py 2015-12-01 17:31:03.143409843 +0800
-@@ -14,7 +14,6 @@
-     author_email="washort42@gmail.com",
-     license="MIT License",
-     long_description=open("README").read(),
--    packages=["ometa", "terml", "ometa._generated", "terml._generated",
--              "ometa.test", "terml.test"],
-+    packages=["ometa", "terml", "ometa._generated", "terml._generated"],
-     py_modules=["parsley"]
- )
diff --git a/lang/python/python-parsley/patches/001-py3-read-utf8.patch b/lang/python/python-parsley/patches/001-py3-read-utf8.patch
new file mode 100644 (file)
index 0000000..f3e63dc
--- /dev/null
@@ -0,0 +1,19 @@
+--- a/setup.py
++++ b/setup.py
+@@ -4,6 +4,7 @@
+ Setup script for the Parsley distribution.
+ """
++import io
+ from distutils.core import setup
+ setup(
+     name="Parsley",
+@@ -13,7 +14,7 @@ setup(
+     author="Allen Short",
+     author_email="washort42@gmail.com",
+     license="MIT License",
+-    long_description=open("README").read(),
++    long_description=io.open("README", encoding="utf-8").read(),
+     packages=["ometa", "terml", "ometa._generated", "terml._generated",
+               "ometa.test", "terml.test"],
+     py_modules=["parsley"]
diff --git a/lang/python/python-parsley/patches/002-omit-tests.patch b/lang/python/python-parsley/patches/002-omit-tests.patch
new file mode 100644 (file)
index 0000000..4fe43b8
--- /dev/null
@@ -0,0 +1,11 @@
+--- a/setup.py
++++ b/setup.py
+@@ -15,7 +15,6 @@ setup(
+     author_email="washort42@gmail.com",
+     license="MIT License",
+     long_description=io.open("README", encoding="utf-8").read(),
+-    packages=["ometa", "terml", "ometa._generated", "terml._generated",
+-              "ometa.test", "terml.test"],
++    packages=["ometa", "terml", "ometa._generated", "terml._generated"],
+     py_modules=["parsley"]
+ )
index 235f313581cf08308ef970a749add194942ba4f8..6e8baa475b7e46b47ba9b7b7925edf7f895d0571 100644 (file)
@@ -159,6 +159,7 @@ TARGET_CFLAGS += -flto -std=gnu99
 CONFIGURE_VARS += \
        ovs_cv_flake8=no \
        ovs_cv_python3=no \
+       ovs_cv_sphinx=no \
        KARCH=$(LINUX_KARCH)
 
 MAKE_FLAGS += \
index 99999874ec3ab5ee4a051eecb41e0a8c452b459e..fb52e7d72c8aa6179fa06ded0a1894df2dca7fb7 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=usbip
-PKG_RELEASE:=8
+PKG_RELEASE:=9
 PKG_LICENSE:=GPL-2.0
 
 # Since kernel 2.6.39.1 userspace tools are inside the kernel tree
@@ -92,7 +92,7 @@ define Package/usbip/install
        $(INSTALL_DIR) $(1)/usr/lib
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/libusbip.so.* $(1)/usr/lib/
        $(INSTALL_DIR) $(1)/usr/share/hwdata
-       $(CP) $(DL_DIR)/usb.ids $(1)/usr/share/hwdata/
+       $(CP) $(DL_DIR)/usb.ids.$(USB_IDS_REV) $(1)/usr/share/hwdata/usb.ids
 endef
 
 define Package/usbip-client/install