ath79: add support for TP-Link TL-WR841N/ND v10
authorAdrian Schmutzler <freifunk@adrianschmutzler.de>
Mon, 22 Jul 2019 15:34:08 +0000 (17:34 +0200)
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>
Wed, 8 Jan 2020 17:32:52 +0000 (18:32 +0100)
The TL-WR841N/ND v10 is mostly identical to the v9. Apart from some minor
changes, it contains a newer revision of the QCA9533 SoC and the CPU clock
is significantly higher.

Flash instruction (WebUI):
Download *-factory.bin image and upload it via the firmwary upgrade
function of the stock firmware WebUI.

Flash instruction (TFTP):
1. Set PC to fixed ip address 192.168.0.66
2. Download *-factory.bin image and rename it to wr841nv10_tp_recovery.bin
3. Start a tftp server with the image file in its root directory
4. Turn off the router
5. Press and hold Reset button
6. Turn on router with the reset button pressed and wait ~15 seconds
7. Release the reset button and after a short time
the firmware should be transferred from the tftp server
8. Wait ~30 second to complete recovery.

Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
(cherry picked from commit 4254193c1dc27e18baeb7488ac7fd4ce1afc5723)

target/linux/ath79/base-files/etc/board.d/01_leds
target/linux/ath79/base-files/etc/board.d/02_network
target/linux/ath79/dts/qca9533_tplink_tl-wr841-v10.dts [new file with mode: 0644]
target/linux/ath79/dts/qca9533_tplink_tl-wr841-v9.dts
target/linux/ath79/image/tiny-tp-link.mk

index be5d29d97c365ca053dccd16f1580e5edbfdff5d..78d48daf73b11680fa60c2263522ca3c2f8bfe9c 100755 (executable)
@@ -128,6 +128,7 @@ tplink,archer-c6-v2)
        ;;
 tplink,archer-c25-v1|\
 tplink,tl-wr841-v9|\
+tplink,tl-wr841-v10|\
 tplink,tl-wr841-v11|\
 tplink,tl-wr842n-v3)
        ucidef_set_led_netdev "wan" "WAN" "tp-link:green:wan" "eth1"
index b342c8b5e42a67a6f34911618c247b10d51438c2..b511aa0acd6e7bbd1db25b5c030b1d41f8ebcfe3 100755 (executable)
@@ -75,6 +75,7 @@ ath79_setup_interfaces()
        tplink,tl-mr3420-v1|\
        tplink,tl-wr841-v7|\
        tplink,tl-wr841-v9|\
+       tplink,tl-wr841-v10|\
        tplink,tl-wr841-v11|\
        tplink,tl-wr842n-v1|\
        tplink,tl-wr842n-v3|\
diff --git a/target/linux/ath79/dts/qca9533_tplink_tl-wr841-v10.dts b/target/linux/ath79/dts/qca9533_tplink_tl-wr841-v10.dts
new file mode 100644 (file)
index 0000000..2a4d0a1
--- /dev/null
@@ -0,0 +1,16 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+/dts-v1/;
+
+#include "qca9533_tplink_tl-wr841.dtsi"
+
+/ {
+       compatible = "tplink,tl-wr841-v10", "qca,qca9533";
+       model = "TP-Link TL-WR841N/ND v10";
+
+       aliases {
+               led-boot = &qss_led;
+               led-failsafe = &qss_led;
+               led-running = &qss_led;
+               led-upgrade = &qss_led;
+       };
+};
index a3284226a04b9ad3e15ba1098556399fdb404c7b..d8c4546f494665e994dd008003e5805fda3bd81f 100644 (file)
@@ -1,9 +1,6 @@
 // SPDX-License-Identifier: GPL-2.0-or-later OR MIT
 /dts-v1/;
 
-#include <dt-bindings/gpio/gpio.h>
-#include <dt-bindings/input/input.h>
-
 #include "qca9533_tplink_tl-wr841.dtsi"
 
 / {
index fb8ab75cb1dd3e389aa36c0120776d73d15b7e53..d8ada5407cdeb747426437d3c805b159395ea74a 100644 (file)
@@ -153,6 +153,14 @@ define Device/tplink_tl-wr841-v9
 endef
 TARGET_DEVICES += tplink_tl-wr841-v9
 
+define Device/tplink_tl-wr841-v10
+  $(Device/tplink-4mlzma)
+  ATH_SOC := qca9533
+  DEVICE_TITLE := TP-Link TL-WR841N/ND v10
+  TPLINK_HWID := 0x08410010
+endef
+TARGET_DEVICES += tplink_tl-wr841-v10
+
 define Device/tplink_tl-wr841-v11
   $(Device/tplink-4mlzma)
   ATH_SOC := qca9533