packages/cups: use new service functions
authorNicolas Thill <nico@openwrt.org>
Wed, 9 Nov 2011 23:37:58 +0000 (23:37 +0000)
committerNicolas Thill <nico@openwrt.org>
Wed, 9 Nov 2011 23:37:58 +0000 (23:37 +0000)
SVN-Revision: 28910

net/cups/Makefile
net/cups/files/cupsd.init

index fad3994195d7e24152d92c78433bda48a545115e..309f12497b5805a3d7296693285ac38af527b56e 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006-2010 OpenWrt.org
+# Copyright (C) 2006-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=cups
 PKG_VERSION:=1.4.4
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-source.tar.bz2
 PKG_SOURCE_URL:= \
index ebbda23d8f2dadd363e611c403b917e049659f6c..e5f00da9a48d8c8cf690afd51c4b7acf43f20a6a 100644 (file)
@@ -1,14 +1,19 @@
 #!/bin/sh /etc/rc.common
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2011 OpenWrt.org
+
 START=50
 
 start() {
-       mkdir -p /var/cache/cups
-       mkdir -p /var/cups
-       mkdir -p /var/spool/cups/tmp
-       /usr/sbin/cupsd
+       mkdir -m 0755 -p /var/cache/cups
+       mkdir -m 0755 -p /var/cups
+       mkdir -m 0755 -p /var/spool/cups/tmp
+       service_start /usr/sbin/cupsd
 }
 
 stop() {
-       killall cupsd
+       service_stop /usr/sbin/cupsd
+}
+
+reload() {
+       service_reload /usr/sbin/cupsd
 }