Merge pull request #711 from micmac1/2102-dongle-fixes
authormicmac1 <sebastian_ml@gmx.net>
Tue, 9 Nov 2021 18:26:19 +0000 (19:26 +0100)
committerGitHub <noreply@github.com>
Tue, 9 Nov 2021 18:26:19 +0000 (19:26 +0100)
[21.02] asterisk + asterisk-chan-dongle fixes

net/asterisk-chan-dongle/Makefile
net/asterisk-chan-dongle/patches/200-fix-iconv-detection.patch
net/asterisk-chan-dongle/patches/300-use-openwrt-flags.patch
net/asterisk/Makefile
net/asterisk/files/asterisk.init

index 2ef0c21531afd92d04f92f195722c2125b45272f..0a359b7fa3fff59dc6c55d1a85888f5e0d9ce92c 100644 (file)
@@ -11,10 +11,10 @@ PKG_NAME:=asterisk-chan-dongle
 
 PKG_SOURCE_PROTO:=git
 PKG_SOURCE_URL:=https://github.com/wdoekes/asterisk-chan-dongle.git
-PKG_SOURCE_VERSION:=328b2b7ded3b3c59c2e6c7e7afca6b0ac6f146ce
-PKG_SOURCE_DATE=2020-05-28
+PKG_SOURCE_VERSION:=3d2a97f26ba84473a0926a9fe9a32e451a56bc36
+PKG_SOURCE_DATE=2021-09-29
 PKG_RELEASE:=1
-PKG_MIRROR_HASH:=b0af444840340722ecee111a7b1f819de441acf290799ae11bc18e16569c6388
+PKG_MIRROR_HASH:=b5baf737d39d522fa9b7055dea72c2d3241c272b20354fdf2a3bd09cce274844
 
 PKG_FIXUP:=autoreconf
 
@@ -64,4 +64,19 @@ define Package/asterisk-chan-dongle/install
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/chan_dongle.so $(1)$(MODULES_DIR)
 endef
 
+define Package/asterisk-chan-dongle/postinst
+#!/bin/sh
+if [ -z "$${IPKG_INSTROOT}" ]; then
+  echo
+  echo "o-------------------------------------------------------------------o"
+  echo "| asterisk-chan-dongle note                                         |"
+  echo "o-------------------------------------------------------------------o"
+  echo "| Adding the \"asterisk\" user to the \"dialout\" group might be        |"
+  echo "| required for asterisk to be able to access the dongle.            |"
+  echo "o-------------------------------------------------------------=^_^=-o"
+  echo
+fi
+exit 0
+endef
+
 $(eval $(call BuildPackage,asterisk-chan-dongle))
index be7d93354290967ee7a9ba35c97a64ea14020a3b..cd39b160baa5b10f0afc78e3968c1273931537e8 100644 (file)
@@ -1,6 +1,6 @@
 --- a/configure.ac
 +++ b/configure.ac
-@@ -83,7 +83,7 @@ fi
+@@ -90,7 +90,7 @@ fi
  
  dnl Checks for libraries.
  dnl AC_CHECK_LIB([pthread], [pthread_create])  # should use ast_pthread_join everywhere?
index f1c48500ccf2398f64c49893592dbfa199a3fea9..1dea4b492f9f4b3fbe645b7f12e8a7ad7380cb5f 100644 (file)
@@ -1,8 +1,8 @@
 --- a/configure.ac
 +++ b/configure.ac
-@@ -224,8 +224,6 @@ dnl Apply options to defines
+@@ -237,8 +237,6 @@ dnl Apply options to defines
  if test "x$enable_debug" = "xyes" ; then
-   CFLAGS="$CFLAGS -O0 -g"
+   CFLAGS="$CFLAGS -O0 -g3"
    AC_DEFINE([__DEBUG__], [1], [Build with debugging])
 -else
 -  CFLAGS="$CFLAGS -O6"
index 2293a573f951d95d60822afffecb838bac52d9a4..8cc8755df63dba70201ef1115ecda7788e285c63 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=asterisk
 PKG_VERSION:=18.5.1
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=asterisk-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=https://downloads.asterisk.org/pub/telephony/asterisk/releases
index 256a3cf727125c2fe3745a017c33e4c7e374d4f7..0e267e7144225345be7760a815ed6abbd9267ab9 100644 (file)
@@ -51,7 +51,6 @@ start_service() {
   procd_open_instance
   procd_set_param command $COMMAND
   procd_append_param command \
-    -G "$NAME" \
     -U "$NAME" \
     $options \
     -f