libowfat: try to fix compilation under ARC
authorRosen Penev <rosenp@gmail.com>
Thu, 9 Jun 2022 02:02:40 +0000 (19:02 -0700)
committerRosen Penev <rosenp@gmail.com>
Tue, 21 Jun 2022 00:20:04 +0000 (18:20 -0600)
CFLAGS are not being passed.

Signed-off-by: Rosen Penev <rosenp@gmail.com>
libs/libowfat/Makefile
libs/libowfat/patches/020-cflags.patch [new file with mode: 0644]

index 8e57a5547dfb4fbb98903b286f1247f7b294cb3a..325822ae1f71b5dbec6eb96cf911475e77e249cc 100644 (file)
@@ -6,7 +6,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=libowfat
 PKG_VERSION:=0.32
-PKG_RELEASE:=3
+PKG_RELEASE:=4
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=https://www.fefe.de/libowfat
diff --git a/libs/libowfat/patches/020-cflags.patch b/libs/libowfat/patches/020-cflags.patch
new file mode 100644 (file)
index 0000000..78ff583
--- /dev/null
@@ -0,0 +1,13 @@
+--- a/Makefile
++++ b/Makefile
+@@ -37,8 +37,8 @@ OPT_PLUS=-O3 $(NATIVE)
+ DEFINE=-D_REENTRANT
+-CFLAGS=-pipe $(WARN) $(DEFINE) $(OPT_REG)
+-CFLAGS_OPT=-pipe $(WARN) $(DEFINE) $(OPT_PLUS)
++CFLAGS+=-pipe $(WARN) $(DEFINE) $(OPT_REG)
++CFLAGS_OPT+=-pipe $(WARN) $(DEFINE) $(OPT_PLUS)
+ #CFLAGS=-pipe -Os -march=pentiumpro -mcpu=pentiumpro -fomit-frame-pointer -fschedule-insns2 -Wall