tvheadend: update to git master 2022-11-20
authorMarius Dinu <m95d+git@psihoexpert.ro>
Mon, 21 Nov 2022 10:42:59 +0000 (12:42 +0200)
committerHannu Nyman <hannu.nyman@iki.fi>
Tue, 22 Nov 2022 14:50:59 +0000 (16:50 +0200)
- EPG database switched from v2 to v3. This commit updates OpenWrt init script to use the new database file.
- EPG database symlink created by OpenWrt config option is overwritten with a real file by tvheadend.
  The latest tvheadend commit included here fixes that.

Signed-off-by: Marius Dinu <m95d+git@psihoexpert.ro>
multimedia/tvheadend/Makefile
multimedia/tvheadend/files/tvheadend.init

index f4358e166ff6d0484ef5e2117b28617146b96d2e..c6a01e20359a9bdc01105b2339196937b54f49c1 100644 (file)
@@ -1,14 +1,14 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=tvheadend
-PKG_VERSION:=2021-11-16
+PKG_VERSION:=2022-11-20
 PKG_RELEASE:=$(AUTORELEASE)
 
 PKG_SOURCE_PROTO:=git
 PKG_SOURCE_URL:=https://github.com/tvheadend/tvheadend.git
-PKG_MIRROR_HASH:=1645e90b6b8f104f2749fb0911493010f7ae3176253f2a96a4d6094536207c03
-PKG_SOURCE_VERSION:=2efe90cdcf74fdc4179692d283cf46c85e1cf681
-PKG_SOURCE_DATE:=2021-11-16
+PKG_MIRROR_HASH:=9c1bb3eea3f3539454d17e4c6aabc774a104a772aa34ed39f248521cf6488ce5
+PKG_SOURCE_VERSION:=0ff96106aa2e0f9a384c3a2662ca005797a6b399
+PKG_SOURCE_DATE:=2022-11-20
 
 PKG_LICENSE:=GPL-3.0
 PKG_LICENSE_FILES:=LICENSE.md
@@ -220,6 +220,7 @@ CONFIGURE_ARGS += \
        --disable-pcloud_cache \
        --enable-bundle \
        --disable-uriparser \
+       --disable-execinfo \
        --nowerror=unused-variable
 
 ## Transcoding | Remove these from CONFIGURE_ARGS.
index b47d25c7d77b3fe8e8ed30e796d8e824f2fea96c..181bf62d86c1a9245ec6225f2eb4344284f28e4d 100644 (file)
@@ -18,11 +18,12 @@ TVH_GROUP=dvb
 
 
 execute_first_run() {
+       # $1 is the config dir. Default: /etc/tvheadend
        mkdir -p "$1"
        chown -R $TVH_USER "$1"
        # This should create a new configuration including an admin account with no name and no password,
        # but it aborts (-A) without saving it:
-       #"$PROG" -c "$1" -B -C -A -u $TVH_USER -g $TVH_GROUP >/dev/null 2>&1
+       # "$PROG" -c "$1" -B -C -A -u $TVH_USER -g $TVH_GROUP >/dev/null 2>&1
        # Instead, run it for 10s then kill it:
        "$PROG" -c "$1" -B -C -u $TVH_USER -g $TVH_GROUP & TVH_PID=$! ; sleep 10 ; kill $TVH_PID ; sleep 2
 }
@@ -41,15 +42,15 @@ ensure_config_exists() {
        fi
 
        # if use_temp_epgdb is enabled (default), most of the config is put to config_path
-       # (or /etc/config), except for epgdb.v2, which grows quite large and is write-heavy,
+       # (or /etc/config), except for epgdb.v3, which grows quite large and is write-heavy,
        # so it's put into volatile tmpfs
-       # epgdb.v2 is created and symlinked to main config dir upon each start (if it doesn't exist)
+       # epgdb.v3 is created and symlinked to main config dir upon each start (if it doesn't exist)
        config_get_bool use_temp_epgdb service use_temp_epgdb 1
        if [ "$use_temp_epgdb" == "1" ]; then
-               TEMP_EPG="${TEMP_CONFIG}/epgdb.v2"
-               [ ! -f "$TEMP_EPG" ] && mkdir -p "$TEMP_CONFIG" && touch "$TEMP_EPG" && chmod 700 "$TEMP_EPG"
+               TEMP_EPG="${TEMP_CONFIG}/epgdb.v3"
+               [ ! -f "$TEMP_EPG" ] && mkdir -p "$TEMP_CONFIG" && touch "$TEMP_EPG" && chmod 755 "$TEMP_CONFIG" && chmod 644 "$TEMP_EPG" && chown -R $TVH_USER "$TEMP_CONFIG"
                [ -z "$config_path" ] && config_path="$PERSISTENT_CONFIG"
-               ln -sf "$TEMP_EPG" "${config_path}/epgdb.v2"
+               ln -sf "$TEMP_EPG" "${config_path}/epgdb.v3"
        fi
 }