transmission: fix build problem with fallocate64 1089/head
authorCezary Jackiewicz <cezary.jackiewicz@gmail.com>
Sun, 29 Mar 2015 10:35:33 +0000 (12:35 +0200)
committerCezary Jackiewicz <cezary.jackiewicz@gmail.com>
Sun, 29 Mar 2015 10:35:33 +0000 (12:35 +0200)
net/transmission/Makefile
net/transmission/patches/010_libtransmission_fallocate64_eglibc.patch

index df74fd566e75a5cac19547208b4029763972f9c9..1facadaf8dbb463b1e9b76abcbeb02761fefc165 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=transmission
 PKG_VERSION:=2.84
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=http://download-origin.transmissionbt.com/files/ http://mirrors.m0k.org/transmission/files
index d4f82fc2cd16a807bc98995d755ecad28dc8286b..e46a1ad98fe7bd5412049475edc5a7c6c25bb84c 100644 (file)
@@ -1,12 +1,14 @@
---- a/libtransmission/fdlimit.c        2014-07-01 20:08:59.000000000 +0300
-+++ b/libtransmission/fdlimit.c        2014-07-13 13:30:17.000000000 +0300
-@@ -22,7 +22,8 @@
+--- a/libtransmission/fdlimit.c
++++ b/libtransmission/fdlimit.c
+@@ -22,11 +22,6 @@
   #include <fcntl.h>
  #endif
+
 -#ifdef HAVE_FALLOCATE64
-+/* no need to define fallocate64 in glibc/eglibc case */
-+#if defined(__UCLIBC__) && (HAVE_FALLOCATE64)
-   /* FIXME can't find the right #include voodoo to pick up the declaration.. */
-   extern int fallocate64 (int fd, int mode, uint64_t offset, uint64_t len);
+-  /* FIXME can't find the right #include voodoo to pick up the declaration.. */
+-  extern int fallocate64 (int fd, int mode, uint64_t offset, uint64_t len);
+-#endif
+-
+ #ifdef HAVE_XFS_XFS_H
+  #include <xfs/xfs.h>
  #endif