acpid: fix init script 12341/head
authorRob Mosher <nyt-openwrt@countercultured.net>
Wed, 27 May 2020 10:48:34 +0000 (06:48 -0400)
committerRob Mosher <nyt-github@countercultured.net>
Wed, 27 May 2020 10:48:34 +0000 (06:48 -0400)
init script would error:

procd: /etc/rc.d/S99acpid: /etc/rc.common: /etc/rc.d/S99acpid: line 18: procd_send_signal: not found
procd: /etc/rc.d/S99acpid: /etc/rc.common: /etc/rc.d/S99acpid: line 19: syntax error: unexpected "}"

Signed-off-by: Rob Mosher <nyt-openwrt@countercultured.net>
utils/acpid/Makefile
utils/acpid/files/acpid.init

index 5217c29627fc67963650afbe6258e2adcdc11f67..9328cbd7ea48a59f8c750604f5f25969175ace3e 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=acpid
 PKG_VERSION:=2.0.32
-PKG_RELEASE:=2
+PKG_RELEASE:=3
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=@SF/acpid2
index c860327caeef3984cc9c2f9ed7b2c9496a6e6744..411eea255a2392ceea7ad2fddd1d0755177732b9 100644 (file)
@@ -1,4 +1,4 @@
-#!/bin/ash /etc/rc.common
+#!/bin/sh /etc/rc.common
 # Copyright (C) 2009-2010 OpenWrt.org
 
 START=99
@@ -14,6 +14,6 @@ start_service() {
        procd_set_param pidfile "/var/run/acpid.pid"
 }
 
-reload_service()\ {
+reload_service() {
        procd_send_signal "acpid"
 }