Merge pull request #585 from chewi/master
authorMichael Heimpold <mhei@heimpold.de>
Thu, 4 Dec 2014 19:41:48 +0000 (20:41 +0100)
committerMichael Heimpold <mhei@heimpold.de>
Thu, 4 Dec 2014 19:41:48 +0000 (20:41 +0100)
libxml2: Fix zlib detection the right way

22 files changed:
ipv6/aiccu/Makefile
ipv6/aiccu/files/aiccu.hotplug [new file with mode: 0644]
ipv6/aiccu/files/aiccu.sh
libs/libimobiledevice/Makefile
libs/libplist/Makefile
libs/libusbmuxd/Makefile
multimedia/gst1-libav/Makefile
multimedia/gst1-plugins-bad/Makefile
multimedia/gst1-plugins-base/Makefile
multimedia/gst1-plugins-good/Makefile
multimedia/gst1-plugins-ugly/Makefile
multimedia/gstreamer1/Makefile
net/coova-chilli/Config.in
net/coova-chilli/Makefile
net/git/Makefile
net/git/patches/100-convert_builtin.patch
net/nmap/Makefile
net/openvswitch/Makefile
net/openvswitch/patches/0004-datapath-Use-ccflags-y-instead-of-deprecated-EXTRA_C.patch [new file with mode: 0644]
net/openvswitch/patches/0004-datapath-linux-add-KCFLAGS-var-to-modules-Makefile.m.patch [deleted file]
net/strongswan/Makefile
utils/usbmuxd/Makefile

index bfa8a83206c2f09c417ea2889a40ced1715fea54..50839f359a3c2794e7a16ac0c295a4c015f4dc19 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=aiccu
 PKG_VERSION:=20070115
-PKG_RELEASE:=11
+PKG_RELEASE:=12
 
 PKG_SOURCE:=$(PKG_NAME)_$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://www.sixxs.net/archive/sixxs/aiccu/unix
@@ -47,9 +47,10 @@ define Package/aiccu/conffiles
 endef
 
 define Package/aiccu/install
-       $(INSTALL_DIR) $(1)/usr/sbin $(1)/lib/netifd/proto
+       $(INSTALL_DIR) $(1)/usr/sbin $(1)/lib/netifd/proto $(1)/etc/hotplug.d/ntp
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/unix-console/$(PKG_NAME) $(1)/usr/sbin/
        $(INSTALL_BIN) ./files/aiccu.sh $(1)/lib/netifd/proto/aiccu.sh
+       $(INSTALL_DATA) ./files/aiccu.hotplug $(1)/etc/hotplug.d/ntp/10-aiccu
 endef
 
 $(eval $(call BuildPackage,aiccu))
diff --git a/ipv6/aiccu/files/aiccu.hotplug b/ipv6/aiccu/files/aiccu.hotplug
new file mode 100644 (file)
index 0000000..b521371
--- /dev/null
@@ -0,0 +1,3 @@
+#!/bin/sh
+NTPSTRATUMFILE="/var/run/aiccu_ntp_stratum"
+echo $stratum > "$NTPSTRATUMFILE"
index 669e0e257fbbc215c7e106d48e82dea481992185..38d8191f502fdc3ab9e3e1508238532081c874c3 100755 (executable)
@@ -14,8 +14,8 @@ proto_aiccu_setup() {
        local iface="$2"
        local link="aiccu-$cfg"
 
-       local username password protocol server ip6prefix tunnelid requiretls defaultroute nat heartbeat verbose sourcerouting ip6addr
-       json_get_vars username password protocol server ip6prefix tunnelid requiretls defaultroute nat heartbeat verbose sourcerouting ip6addr
+       local username password protocol server ip6prefix tunnelid requiretls defaultroute nat heartbeat verbose sourcerouting ip6addr ntpsynctimeout
+       json_get_vars username password protocol server ip6prefix tunnelid requiretls defaultroute nat heartbeat verbose sourcerouting ip6addr ntpsynctimeout
 
        [ -z "$username" -o -z "$password" ] && {
                proto_notify_error "$cfg" "MISSING_USERNAME_OR_PASSWORD"
@@ -27,21 +27,32 @@ proto_aiccu_setup() {
 
        CFGFILE="/var/etc/${link}.conf"
        PIDFILE="/var/run/${link}.pid"
+       NTPSTRATUMFILE="/var/run/aiccu_ntp_stratum"
        mkdir -p /var/run /var/etc
 
        echo "username $username" > "$CFGFILE"
        echo "password $password" >> "$CFGFILE"
-       echo "ipv6_interface $link"   >> "$CFGFILE"
+       echo "ipv6_interface $link" >> "$CFGFILE"
        [ -n "$server" ] && echo "server $server" >> "$CFGFILE"
        [ -n "$protocol" ] && echo "protocol $protocol" >> "$CFGFILE"
-       [ -n "$tunnelid" ] && echo "tunnel_id $tunnelid"          >> "$CFGFILE"
-       [ -n "$requiretls" ] && echo "requiretls $requiretls"      >> "$CFGFILE"
-       [ "$nat" == 1 ] && echo "behindnat true"     >> "$CFGFILE"
-       [ "$heartbeat"  == 1 ] && echo "makebeats true" >> "$CFGFILE"
+       [ -n "$tunnelid" ] && echo "tunnel_id $tunnelid" >> "$CFGFILE"
+       [ -n "$requiretls" ] && echo "requiretls $requiretls" >> "$CFGFILE"
+       [ "$nat" == 1 ] && echo "behindnat true" >> "$CFGFILE"
+       [ "$heartbeat" == 1 ] && echo "makebeats true" >> "$CFGFILE"
        [ "$verbose" == 1 ] && echo "verbose true" >> "$CFGFILE"
        echo "defaultroute false" >> "$CFGFILE"
-       echo "daemonize true"     >> "$CFGFILE"
-       echo "pidfile $PIDFILE"   >> "$CFGFILE"
+       echo "daemonize true" >> "$CFGFILE"
+       echo "pidfile $PIDFILE" >> "$CFGFILE"
+
+       # By default, wait at most 90 seconds for NTP sync
+       [ -z "$ntpsynctimeout" ] && ntpsynctimeout=90
+       for i in $(seq 1 $ntpsynctimeout); do
+               [ -f "$NTPSTRATUMFILE" ] && \
+               [ "$(cat $NTPSTRATUMFILE)" -lt 16 ] && \
+               echo "NTP synced, stratum $(cat $NTPSTRATUMFILE)" && break
+               [ "$(( $i % 10 ))" -eq 0 ] && echo "Waiting ${i} secs for NTP sync..."
+               sleep 1
+       done
 
        aiccu start "$CFGFILE"
 
@@ -78,8 +89,12 @@ proto_aiccu_teardown() {
        local cfg="$1"
        local link="aiccu-$cfg"
        CFGFILE="/var/etc/${link}.conf"
-
-       aiccu stop "$CFGFILE"
+       PIDFILE="/var/run/${link}.pid"
+       [ -f "$CFGFILE" -a -f "$PIDFILE" ] && {
+               local pid="$(cat "$PIDFILE")"
+               [ -d /proc/$pid -a $(cat /proc/$pid/comm) = "aiccu" ] && \
+               aiccu stop "$CFGFILE"
+       }
 }
 
 proto_aiccu_init_config() {
@@ -98,6 +113,7 @@ proto_aiccu_init_config() {
        proto_config_add_boolean "nat"
        proto_config_add_boolean "heartbeat"
        proto_config_add_boolean "verbose"
+       proto_config_add_int "ntpsynctimeout"
 }
 
 [ -n "$INCLUDE_ONLY" ] || {
index cd61903a4cc0dbac1d64ce3db02b18013d551cc8..7cb06224c16eefb27c3217a694c76e25d4023d57 100644 (file)
@@ -8,7 +8,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=libimobiledevice
-PKG_VERSION:=1.1.6
+PKG_VERSION:=1.2.0
 PKG_RELEASE:=1
 
 PKG_MAINTAINER:=Lukasz Baj <l.baj@radytek.com>
@@ -18,7 +18,7 @@ PKG_LICENSE_FILES:=COPYING.LESSER
 PKG_SOURCE_PROTO:=git
 PKG_SOURCE_URL:=https://github.com/libimobiledevice/libimobiledevice.git
 PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
-PKG_SOURCE_VERSION:=9732d275d00bb1200d2b6180d94814a1a7fb7696
+PKG_SOURCE_VERSION:=53eb963f8e6d607cca6b50381c10820a5e8357f4
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION).tar.gz
 
 PKG_FIXUP:=autoreconf
index 0b7ed51b878c6d8eb93083a470b1996f2ff592ed..4d7cb9c86ae965a91aa26a585ceac5272a11d21f 100644 (file)
@@ -8,7 +8,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=libplist
-PKG_VERSION:=1.11
+PKG_VERSION:=1.13
 PKG_RELEASE:=1
 
 PKG_MAINTAINER:=Lukasz Baj <l.baj@radytek.com>
@@ -18,7 +18,7 @@ PKG_LICENSE_FILES:=COPYING.LESSER
 PKG_SOURCE_PROTO:=git
 PKG_SOURCE_URL:=https://github.com/libimobiledevice/libplist.git
 PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
-PKG_SOURCE_VERSION:=063c629baef6028e84838f77fd1401b05e41dc58
+PKG_SOURCE_VERSION:=cc907c0f162ee84e5698b9c27ac6fb0be8bb9bc0
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION).tar.gz
 
 PKG_FIXUP:=autoreconf
index 451f849628bc367f2441495ec7d9914bbd48d663..ec15bc2d2a37e9169f6b971e835120402e42d9cc 100644 (file)
@@ -8,7 +8,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=libusbmuxd
-PKG_VERSION:=1.0.9
+PKG_VERSION:=1.1.0
 PKG_RELEASE:=1
 
 PKG_MAINTAINER:=Lukasz Baj <l.baj@radytek.com>
@@ -18,7 +18,7 @@ PKG_LICENSE_FILES:=COPYING.LGPLv2.1
 PKG_SOURCE_PROTO:=git
 PKG_SOURCE_URL:=https://github.com/libimobiledevice/libusbmuxd.git
 PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
-PKG_SOURCE_VERSION:=ca68e3c287a8410fbef5280948a6d1d2255e0a89
+PKG_SOURCE_VERSION:=f347085157006523622b0a7160be68d14f037c00
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION).tar.gz
 
 PKG_FIXUP:=autoreconf
index 600fb670e4f91736ea346bd183b71a2d5080312f..81ce237b34ac3f8176e669b0aa42f135eec52382 100644 (file)
@@ -8,14 +8,14 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=gst1-libav
-PKG_VERSION:=1.2.3
-PKG_RELEASE:=2
+PKG_VERSION:=1.4.4
+PKG_RELEASE:=1
 
 PKG_MAINTAINER:=W. Michael Petullo <mike@flyn.org>
 
 PKG_SOURCE:=gst-libav-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=http://gstreamer.freedesktop.org/src/gst-libav
-PKG_MD5SUM:=58c7998a054d8d8ca041fa35738f72b6
+PKG_MD5SUM:=64a3e2cda2687132cadca4efdc63f3b4
 
 PKG_LICENSE:=GPL-2.0 LGPL-2.0
 PKG_LICENSE_FILES:=COPYING COPYING.LIB
@@ -148,6 +148,7 @@ CONFIGURE_ARGS += \
        --without-system-libav \
        --with-libav-extra-configure="--target-os=linux \
        --disable-bsfs \
+       --disable-programs \
        --disable-devices \
        --disable-encoders \
        $(LIBAV_CONFIGURE_ENCODERS) \
@@ -161,6 +162,26 @@ CONFIGURE_ARGS += \
        $(LIBAV_CONFIGURE_PARSERS) \
        --disable-protocols \
        $(LIBAV_CONFIGURE_PROTOCOLS) \
+       --disable-asm \
+       --disable-altivec \
+       --disable-amd3dnow \
+       --disable-amd3dnowext \
+       --disable-mmx \
+       --disable-mmxext \
+       --disable-sse \
+       --disable-sse2 \
+       --disable-sse3 \
+       --disable-ssse3 \
+       --disable-sse4 \
+       --disable-sse42 \
+       --disable-avx \
+       --disable-xop \
+       --disable-fma3 \
+       --disable-fma4 \
+       --disable-avx2 \
+       --disable-vfp \
+       --disable-neon \
+       --disable-inline-asm \
        --disable-yasm"
 
 # XXX: trick to force use of embedded Libav headers
index 9bed4ef163575a26b0d9cf4c13d982c7a016b45b..63a1efa687a50ef5f2e85a5bdd8cd56ad436431f 100644 (file)
@@ -8,8 +8,8 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=gst1-plugins-bad
-PKG_VERSION:=1.2.3
-PKG_RELEASE:=3
+PKG_VERSION:=1.4.4
+PKG_RELEASE:=1
 
 PKG_MAINTAINER:=W. Michael Petullo <mike@flyn.org>
 
@@ -19,7 +19,7 @@ PKG_LICENSE_FILES:=COPYING.LIB COPYING
 PKG_BUILD_DIR:=$(BUILD_DIR)/gst-plugins-bad-$(PKG_VERSION)
 PKG_SOURCE:=gst-plugins-bad-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=http://gstreamer.freedesktop.org/src/gst-plugins-bad/
-PKG_MD5SUM:=cfd6f303c8df2740b27cc63b945decef
+PKG_MD5SUM:=972c6e22dd2e44fcf0b04b9d810a56be
 
 PKG_BUILD_DEPENDS:= libgstreamer1 gstreamer1-plugins-base liboil
 
index 6fd667caf0fdd7f4bc45e24f80dc1fa629b4635a..9998514e01bede541ba2f922d78bbace2b8089fe 100644 (file)
@@ -8,8 +8,8 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=gst1-plugins-base
-PKG_VERSION:=1.2.3
-PKG_RELEASE:=3
+PKG_VERSION:=1.4.4
+PKG_RELEASE:=1
 
 PKG_MAINTAINER:=W. Michael Petullo <mike@flyn.org>
 
@@ -19,7 +19,7 @@ PKG_LICENSE_FILES:=COPYING.LIB COPYING
 PKG_BUILD_DIR:=$(BUILD_DIR)/gst-plugins-base-$(PKG_VERSION)
 PKG_SOURCE:=gst-plugins-base-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=http://gstreamer.freedesktop.org/src/gst-plugins-base/
-PKG_MD5SUM:=17aeabfbcd232526f50c9bee375f1b97
+PKG_MD5SUM:=0c42eca8f9e4efd56d2ce8e9249ce4a1
 
 PKG_BUILD_DEPENDS:= libgstreamer1 liboil
 PKG_CONFIG_DEPENDS:= \
@@ -157,7 +157,6 @@ EXTRA_LDFLAGS+= \
        -Wl,-rpath-link=$(STAGING_DIR)/usr/lib \
        $(if $(ICONV_FULL),-liconv) \
 
-
 define Build/InstallDev
        $(INSTALL_DIR) $(1)/usr/include/gstreamer-$(GST_VERSION)
        ( cd $(PKG_INSTALL_DIR); $(CP) \
index 1371a6f7e8a6edfca9334841c7654a77ae008e2a..f368eeafddd30dd972f95020de089f556d58efee 100644 (file)
@@ -8,8 +8,8 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=gst1-plugins-good
-PKG_VERSION:=1.2.3
-PKG_RELEASE:=2
+PKG_VERSION:=1.4.4
+PKG_RELEASE:=1
 
 PKG_MAINTAINER:=W. Michael Petullo <mike@flyn.org>
 
@@ -19,7 +19,7 @@ PKG_LICENSE_FILES:=COPYING
 PKG_BUILD_DIR:=$(BUILD_DIR)/gst-plugins-good-$(PKG_VERSION)
 PKG_SOURCE:=gst-plugins-good-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=http://gstreamer.freedesktop.org/src/gst-plugins-good/
-PKG_MD5SUM:=1a1f96bc27ad446e559474299160a9a8
+PKG_MD5SUM:=673cf9276952bd3937dafd817c9ead2b
 
 PKG_BUILD_DEPENDS:= libgstreamer1 gstreamer1-plugins-base liboil
 
index f7e699ac35ffb1ef53c97d85b7ff87d4b0b17492..b8ed67080fe6eff3fb5d959ae4ec4abd7e799177 100644 (file)
@@ -8,8 +8,8 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=gst1-plugins-ugly
-PKG_VERSION:=1.2.3
-PKG_RELEASE:=2
+PKG_VERSION:=1.4.4
+PKG_RELEASE:=1
 
 PKG_MAINTAINER:=W. Michael Petullo <mike@flyn.org>
 
@@ -19,7 +19,7 @@ PKG_LICENSE_FILES:=COPYING
 PKG_BUILD_DIR:=$(BUILD_DIR)/gst-plugins-ugly-$(PKG_VERSION)
 PKG_SOURCE:=gst-plugins-ugly-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=http://gstreamer.freedesktop.org/src/gst-plugins-ugly/
-PKG_MD5SUM:=7ae60e2f759f58f32af5fcdc3c9193c4
+PKG_MD5SUM:=abd832c5cab1a37fb1d9d15fb08e6e59
 
 PKG_BUILD_DEPENDS:= libgstreamer1 gstreamer1-plugins-base liboil
 PKG_CONFIG_DEPENDS:= \
index 5ee7164bf3565d61572a43473602ccf4d622b170..d477fd8f7e3be549a755f3e55f7cb298a7fff6c1 100644 (file)
@@ -8,8 +8,8 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=gstreamer1
-PKG_VERSION:=1.2.3
-PKG_RELEASE:=4
+PKG_VERSION:=1.4.4
+PKG_RELEASE:=1
 
 PKG_MAINTAINER:=W. Michael Petullo <mike@flyn.org>
 
@@ -19,7 +19,7 @@ PKG_LICENSE_FILES:=COPYING
 PKG_BUILD_DIR:=$(BUILD_DIR)/gstreamer-$(PKG_VERSION)
 PKG_SOURCE:=gstreamer-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=http://gstreamer.freedesktop.org/src/gstreamer/
-PKG_MD5SUM:=8155b9c7574ccaa361cc504e8e0e72dc
+PKG_MD5SUM:=98f4a6d45a28dd195144baef0244ba38
 
 PKG_FIXUP:=autoreconf
 PKG_REMOVE_FILES:=autogen.sh aclocal.m4
index 79171f3d89ccbdd06035f77de54e9df29db8b334..74877c293cf8775cb92993aea0ba753ec9532eec 100644 (file)
@@ -3,6 +3,10 @@
 menu "Configuration"
        depends on PACKAGE_coova-chilli
 
+config COOVACHILLI_PROXY
+        bool "Enable support for chilli proxy. Required for AAA Proxy through http"
+        default n
+
 config COOVACHILLI_REDIR
        bool "Enable support for redir server. Required for uamregex"
        default n
index 0498f9322504c84810829c75342c6733e5cabdc9..b6adaf319279d10beb9e2eb30352e11d02a2f9e3 100644 (file)
@@ -72,6 +72,7 @@ endef
 
 define Build/Configure
        $(call Build/Configure/Default, \
+       $(if $(CONFIG_COOVACHILLI_PROXY),--enable,--disable)-chilliproxy \
        $(if $(CONFIG_COOVACHILLI_REDIR),--enable,--disable)-chilliredir \
        $(if $(CONFIG_COOVACHILLI_DNSLOG),--enable,--disable)-dnslog \
        $(if $(CONFIG_COOVACHILLI_MINIPORTAL),--enable,--disable)-miniportal \
index e36790ece207fa1dc29d11c524fb70b0ce3d6989..a909e77fa489da034cfebd36dec7011c90537ea8 100644 (file)
@@ -8,12 +8,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=git
-PKG_VERSION:=2.1.0
-PKG_RELEASE:=2
+PKG_VERSION:=2.2.0
+PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=@KERNEL/software/scm/git/
-PKG_MD5SUM:=47b1f55d9a16be112f7ae2c778a9b30c
+PKG_MD5SUM:=5c9d20582297f8f24606fe49f515b584
 
 PKG_INSTALL:=1
 PKG_BUILD_PARALLEL:=1
index e883921e54a0b6597c6a00216dd543d058d191b2..e7ded54dac3b54c1b1307363e1e478f216c6c5f8 100644 (file)
@@ -1,6 +1,6 @@
 --- a/Makefile
 +++ b/Makefile
-@@ -533,16 +533,7 @@ EXTRA_PROGRAMS =
+@@ -529,16 +529,7 @@ EXTRA_PROGRAMS =
  # ... and all the rest that could be moved out of bindir to gitexecdir
  PROGRAMS += $(EXTRA_PROGRAMS)
  
@@ -18,7 +18,7 @@
  
  # Binary suffix, set to .exe for Windows builds
  X =
-@@ -1007,6 +998,12 @@ BUILTIN_OBJS += builtin/verify-commit.o
+@@ -887,6 +878,12 @@ BUILTIN_OBJS += builtin/verify-commit.o
  BUILTIN_OBJS += builtin/verify-pack.o
  BUILTIN_OBJS += builtin/verify-tag.o
  BUILTIN_OBJS += builtin/write-tree.o
@@ -31,7 +31,7 @@
  
  GITLIBS = $(LIB_FILE) $(XDIFF_LIB)
  EXTLIBS =
-@@ -1174,7 +1171,7 @@ endif
+@@ -1049,7 +1046,7 @@ endif
  EXTLIBS += -lz
  
  ifndef NO_OPENSSL
@@ -40,7 +40,7 @@
        ifdef OPENSSLDIR
                BASIC_CFLAGS += -I$(OPENSSLDIR)/include
                OPENSSL_LINK = -L$(OPENSSLDIR)/$(lib) $(CC_LD_DYNPATH)$(OPENSSLDIR)/$(lib)
-@@ -2067,10 +2064,6 @@ endif
+@@ -1895,10 +1892,6 @@ endif
  git-%$X: %.o GIT-LDFLAGS $(GITLIBS)
        $(QUIET_LINK)$(CC) $(ALL_CFLAGS) -o $@ $(ALL_LDFLAGS) $(filter %.o,$^) $(LIBS)
  
@@ -51,7 +51,7 @@
  git-http-fetch$X: http.o http-walker.o http-fetch.o GIT-LDFLAGS $(GITLIBS)
        $(QUIET_LINK)$(CC) $(ALL_CFLAGS) -o $@ $(ALL_LDFLAGS) $(filter %.o,$^) \
                $(LIBS) $(CURL_LIBCURL)
-@@ -2388,24 +2381,22 @@ endif
+@@ -2216,24 +2209,22 @@ endif
        bindir=$$(cd '$(DESTDIR_SQ)$(bindir_SQ)' && pwd) && \
        execdir=$$(cd '$(DESTDIR_SQ)$(gitexec_instdir_SQ)' && pwd) && \
        { test "$$bindir/" = "$$execdir/" || \
@@ -80,7 +80,7 @@
        done && \
 --- a/builtin.h
 +++ b/builtin.h
-@@ -137,5 +137,11 @@ extern int cmd_verify_pack(int argc, con
+@@ -138,5 +138,11 @@ extern int cmd_verify_pack(int argc, con
  extern int cmd_show_ref(int argc, const char **argv, const char *prefix);
  extern int cmd_pack_refs(int argc, const char **argv, const char *prefix);
  extern int cmd_replace(int argc, const char **argv, const char *prefix);
 +#include "../upload-pack.c"
 --- a/daemon.c
 +++ b/daemon.c
-@@ -1119,7 +1119,7 @@ static int serve(struct string_list *lis
+@@ -1096,7 +1096,7 @@ static int serve(struct string_list *lis
        return service_loop(&socklist);
  }
  
  {
        int listen_port = 0;
        struct string_list listen_addr = STRING_LIST_INIT_NODUP;
-@@ -1315,12 +1315,13 @@
+@@ -1292,12 +1292,13 @@ int main(int argc, char **argv)
                store_pid(pid_file);
  
        /* prepare argv for serving-processes */
  }
 --- a/fast-import.c
 +++ b/fast-import.c
-@@ -3343,7 +3343,7 @@ static void parse_argv(void)
+@@ -3350,7 +3350,7 @@ static void parse_argv(void)
                read_marks();
  }
  
        { "index-pack", cmd_index_pack, RUN_SETUP_GENTLY },
        { "init", cmd_init_db, NO_SETUP },
        { "init-db", cmd_init_db, NO_SETUP },
-@@ -461,6 +464,7 @@ static struct cmd_struct commands[] = {
+@@ -462,6 +465,7 @@ static struct cmd_struct commands[] = {
        { "revert", cmd_revert, RUN_SETUP | NEED_WORK_TREE },
        { "rm", cmd_rm, RUN_SETUP },
        { "send-pack", cmd_send_pack, RUN_SETUP },
        { "shortlog", cmd_shortlog, RUN_SETUP_GENTLY | USE_PAGER },
        { "show", cmd_show, RUN_SETUP },
        { "show-branch", cmd_show_branch, RUN_SETUP },
-@@ -477,6 +481,7 @@ static struct cmd_struct commands[] = {
+@@ -478,6 +482,7 @@ static struct cmd_struct commands[] = {
        { "update-server-info", cmd_update_server_info, RUN_SETUP },
        { "upload-archive", cmd_upload_archive },
        { "upload-archive--writer", cmd_upload_archive_writer },
        { "verify-pack", cmd_verify_pack },
 --- a/http-backend.c
 +++ b/http-backend.c
-@@ -566,7 +566,7 @@ static struct service_cmd {
+@@ -557,7 +557,7 @@ static struct service_cmd {
        {"POST", "/git-receive-pack$", service_rpc}
  };
  
        char *dir;
 --- a/imap-send.c
 +++ b/imap-send.c
-@@ -1365,7 +1365,7 @@ static int git_imap_config(const char *k
-       return 0;
+@@ -1338,7 +1338,7 @@ static void git_imap_config(void)
+       git_config_get_string("imap.authmethod", &server.auth_method);
  }
  
 -int main(int argc, char **argv)
        const char **user_argv;
 --- a/upload-pack.c
 +++ b/upload-pack.c
-@@ -790,7 +790,7 @@ static int upload_pack_config(const char
+@@ -791,7 +791,7 @@ static int upload_pack_config(const char
        return parse_hide_refs_config(var, value, "uploadpack");
  }
  
index 6a8949fa27c0ba7b846ca690e6dfe5465c48198d..251b91e2dbe512b13127ae25a259f0fd749da4f1 100644 (file)
@@ -14,7 +14,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=nmap
 PKG_VERSION:=6.47
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 PKG_MAINTAINER=Nuno Goncalves <nunojpg@gmail.com>
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
@@ -87,7 +87,8 @@ CONFIGURE_ARGS += \
        --with-libdnet=included \
        --with-libpcre=included \
        --with-libpcap="$(STAGING_DIR)/usr" \
-       --without-liblua
+       --without-liblua \
+       --without-zenmap
 
 CONFIGURE_VARS += CXXFLAGS="$$$$CXXFLAGS -fno-builtin"
 
index 397c1da4b21f37dd85985cea79a61f43dfecb029..c0c3e8e15a7b4f408724115c8b8e3ad62b27eef5 100644 (file)
@@ -136,7 +136,7 @@ define Build/Compile
                ARCH="$(LINUX_KARCH)" \
                SUBDIRS="$(PKG_BUILD_DIR)/datapath/linux" \
                PATH="$(TARGET_PATH)" \
-               KCFLAGS="$(KCFLAGS)" \
+               EXTRA_CFLAGS="$(KCFLAGS)" \
                KCC="$(KERNEL_CC)"
 endef
 
diff --git a/net/openvswitch/patches/0004-datapath-Use-ccflags-y-instead-of-deprecated-EXTRA_C.patch b/net/openvswitch/patches/0004-datapath-Use-ccflags-y-instead-of-deprecated-EXTRA_C.patch
new file mode 100644 (file)
index 0000000..95891a1
--- /dev/null
@@ -0,0 +1,41 @@
+From 36fd4f214f9ba74aaf0e5fb3e4ba271b946a1550 Mon Sep 17 00:00:00 2001
+From: Thomas Graf <tgraf@noironetworks.com>
+Date: Wed, 26 Nov 2014 15:52:31 +0100
+Subject: [PATCH] datapath: Use ccflags-y instead of deprecated EXTRA_CFLAGS
+
+This allows users to pass in additional compiler flags through the
+environment variable EXTRA_CFLAGS, e.g.
+
+   make EXTRA_CFLAGS=-Wno-error=foo V=1
+
+Reported-by: Alexandru Ardelean <ardeleanalex@gmail.com>
+Signed-off-by: Thomas Graf <tgraf@noironetworks.com>
+Acked-by: Pravin B Shelar <pshelar@nicira.com>
+---
+ datapath/linux/Kbuild.in | 10 +++++-----
+ 1 file changed, 5 insertions(+), 5 deletions(-)
+
+diff --git a/datapath/linux/Kbuild.in b/datapath/linux/Kbuild.in
+index 6f6f65f..cb98c11 100644
+--- a/datapath/linux/Kbuild.in
++++ b/datapath/linux/Kbuild.in
+@@ -7,11 +7,11 @@ export VERSION = @VERSION@
+ include $(srcdir)/../Modules.mk
+ include $(srcdir)/Modules.mk
+-EXTRA_CFLAGS := -DVERSION=\"$(VERSION)\"
+-EXTRA_CFLAGS += -I$(srcdir)/..
+-EXTRA_CFLAGS += -I$(builddir)/..
+-EXTRA_CFLAGS += -g
+-EXTRA_CFLAGS += -include $(builddir)/kcompat.h
++ccflags-y := -DVERSION=\"$(VERSION)\"
++ccflags-y += -I$(srcdir)/..
++ccflags-y += -I$(builddir)/..
++ccflags-y += -g
++ccflags-y += -include $(builddir)/kcompat.h
+ # These include directories have to go before -I$(KSRC)/include.
+ # NOSTDINC_FLAGS just happens to be a variable that goes in the
+-- 
+2.1.2
+
diff --git a/net/openvswitch/patches/0004-datapath-linux-add-KCFLAGS-var-to-modules-Makefile.m.patch b/net/openvswitch/patches/0004-datapath-linux-add-KCFLAGS-var-to-modules-Makefile.m.patch
deleted file mode 100644 (file)
index bbc758d..0000000
+++ /dev/null
@@ -1,39 +0,0 @@
-From deb44e6e9d64001562ee9395a2c8525848052394 Mon Sep 17 00:00:00 2001
-From: Alexandru Ardelean <aa@ocedo.com>
-Date: Tue, 28 Oct 2014 11:03:53 +0200
-Subject: [PATCH] datapath/linux: add KCFLAGS var to modules Makefile.main.in
-
-This is mostly required because of GCC 4.9 which seems
-to error out with:
-  openvswitch/datapath/linux/datapath.c:2108:10:
-       error: macro "DATE" might prevent reproducible builds
-
-We would have wanted to add '-Wno-error=date-time' directly
-but that would be too specific, so we decided to add
-a generic make flag and configure it with what we need.
-
-Signed-off-by: Alexandru Ardelean <ardeleanalex@gmail.com>
----
- datapath/linux/Makefile.main.in | 4 ++--
- 1 file changed, 2 insertions(+), 2 deletions(-)
-
-diff --git a/datapath/linux/Makefile.main.in b/datapath/linux/Makefile.main.in
-index 88f144c..0b200b7 100644
---- a/datapath/linux/Makefile.main.in
-+++ b/datapath/linux/Makefile.main.in
-@@ -67,10 +67,10 @@ ifeq (,$(wildcard $(CONFIG_FILE)))
- endif
- default:
--      $(MAKE) -C $(KSRC) M=$(builddir) modules
-+      $(MAKE) -C $(KSRC) M=$(builddir) $(KCFLAGS) modules
- modules_install:
--      $(MAKE) -C $(KSRC) M=$(builddir) modules_install
-+      $(MAKE) -C $(KSRC) M=$(builddir) $(KCFLAGS) modules_install
-       depmod `sed -n 's/#define UTS_RELEASE "\([^"]*\)"/\1/p' $(KSRC)/include/generated/utsrelease.h`
- endif
--- 
-1.8.4.5
-
index 58bc004ebede62a44940aba2892b8023e8df210f..d0e67e458418dbf101afc0e3da28e98ddb24d985 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=strongswan
 PKG_VERSION:=5.2.1
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=http://download.strongswan.org/ http://download2.strongswan.org/
@@ -298,22 +298,16 @@ define BuildPlugin
     DEPENDS:= +strongswan $(3)
   endef
 
-  strongswan_mod_conf=$(wildcard $(PKG_INSTALL_DIR)/etc/strongswan.d/charon/$(1).conf)
   define Package/strongswan-mod-$(1)/install
        $(INSTALL_DIR) $$(1)/etc/strongswan.d/charon
-       $(if $(call strongswan_mod_conf,$(1)), \
-               $(INSTALL_DATA) \
-                       $(call strongswan_mod_conf,$(1)) \
-                       $$(1)/etc/strongswan.d/charon/ \
-       )
+       if [ -f $(PKG_INSTALL_DIR)/etc/strongswan.d/charon/$(1).conf ]; then \
+               $(INSTALL_DATA) $(PKG_INSTALL_DIR)/etc/strongswan.d/charon/$(1).conf $$(1)/etc/strongswan.d/charon/; fi
        $(INSTALL_DIR) $$(1)/usr/lib/ipsec/plugins
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/ipsec/plugins/libstrongswan-$(1).so \
                $$(1)/usr/lib/ipsec/plugins/
        $(call Plugin/$(1)/install,$$(1))
   endef
 
-  Package/strongswan-mod-$(1)/conffiles=$(patsubst $(PKG_INSTALL_DIR)%,%,$(call strongswan_mod_conf,$(1)))
-
   $$(eval $$(call BuildPackage,strongswan-mod-$(1)))
 endef
 
index 905f9a96b320a0dd46218e0c4beaf63a33a5ee10..65ab016672157b115c6d9e2ca609aad45a93d03f 100644 (file)
@@ -8,7 +8,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=usbmuxd
-PKG_VERSION:=1.0.8
+PKG_VERSION:=1.1.1
 PKG_RELEASE:=2
 PKG_SOURCE_PROTO:=git
 
@@ -18,7 +18,7 @@ PKG_LICENSE_FILES:=COPYING.GPLv2
 
 PKG_SOURCE_URL:=https://github.com/libimobiledevice/usbmuxd.git
 PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
-PKG_SOURCE_VERSION:=2f6d9d5f7047d4dd5ea9970721ba902301621ab2
+PKG_SOURCE_VERSION:=4bd7cd0d28e7f5920de51470b863f3aeee00409d
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION).tar.gz
 
 PKG_FIXUP:=autoreconf