add tcpdump
authorFelix Fietkau <nbd@openwrt.org>
Mon, 7 Mar 2005 16:27:36 +0000 (16:27 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Mon, 7 Mar 2005 16:27:36 +0000 (16:27 +0000)
SVN-Revision: 340

openwrt/package/Config.in
openwrt/package/Makefile
openwrt/package/tcpdump/Config.in [new file with mode: 0644]
openwrt/package/tcpdump/Makefile [new file with mode: 0644]
openwrt/package/tcpdump/tcpdump.control [new file with mode: 0644]

index ca51d0569eb37deb35a439c8d84b1d48dcaa7818..d4488702c6306cf055b964693ccc35885dc034a9 100644 (file)
@@ -13,6 +13,7 @@ source "package/microperl/Config.in"
 source "package/strace/Config.in"
 
 comment "Networking"
+source "package/tcpdump/Config.in"
 source "package/ppp/Config.in"
 source "package/dropbear/Config.in"
 source "package/ebtables/Config.in"
index 42e222b66057fd178a3b02c2d65acf2d0039d762..ad05ebcc92d9283c7ab46c296e7a77d0cfb7d662 100644 (file)
@@ -21,6 +21,7 @@ package-$(BR2_PACKAGE_IPROUTE2) += iproute2
 package-$(BR2_PACKAGE_MICROPERL) += microperl
 package-$(BR2_PACKAGE_LIBELF) += libelf
 package-$(BR2_PACKAGE_STRACE) += strace
+package-$(BR2_PACKAGE_TCPDUMP) += tcpdump
 
 all: compile install
 clean: $(patsubst %,%-clean,$(package-) $(package-y) $(package-m)) linux-clean
diff --git a/openwrt/package/tcpdump/Config.in b/openwrt/package/tcpdump/Config.in
new file mode 100644 (file)
index 0000000..37956d6
--- /dev/null
@@ -0,0 +1,8 @@
+config BR2_PACKAGE_TCPDUMP
+       tristate "tcpdump"
+       default m
+       help
+         A tool for network monitoring and data acquisition.
+
+         http://www.tcpdump.org/
+
diff --git a/openwrt/package/tcpdump/Makefile b/openwrt/package/tcpdump/Makefile
new file mode 100644 (file)
index 0000000..82abd30
--- /dev/null
@@ -0,0 +1,67 @@
+#############################################################
+#
+# ebtables
+#
+#############################################################
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=tcpdump
+PKG_VERSION:=3.8.3
+PKG_RELEASE:=1
+PKG_SOURCE_URL:=http://www.tcpdump.org/release
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+PKG_CAT:=zcat
+PKG_IPK:=$(PACKAGE_DIR)/$(PKG_NAME)_$(PKG_VERSION)-$(PKG_RELEASE)_$(ARCH).ipk
+PKG_IPK_DIR:=$(PKG_BUILD_DIR)/ipkg
+
+$(DL_DIR)/$(PKG_SOURCE):
+        $(WGET) -P $(DL_DIR) $(PKG_SOURCE_URL)/$(PKG_SOURCE)
+
+$(PKG_BUILD_DIR)/.unpacked: $(DL_DIR)/$(PKG_SOURCE)
+       $(PKG_CAT) $(DL_DIR)/$(PKG_SOURCE) | tar -C $(BUILD_DIR) $(TAR_OPTIONS) -
+       touch $(PKG_BUILD_DIR)/.unpacked
+
+$(PKG_BUILD_DIR)/.configured: $(PKG_BUILD_DIR)/.unpacked
+       (cd $(PKG_BUILD_DIR); rm -rf config.cache; \
+               ac_cv_linux_vers=$(LINUX_VERSION) \
+               BUILD_CC=$(TARGET_CC) HOSTCC=$(HOSTCC) \
+               $(TARGET_CONFIGURE_OPTS) \
+               CFLAGS="$(TARGET_CFLAGS)" \
+               ./configure \
+               --target=$(GNU_TARGET_NAME) \
+               --host=$(GNU_TARGET_NAME) \
+               --build=$(GNU_HOST_NAME) \
+               --with-build-cc=$(HOSTCC) \
+               --prefix=$(STAGING_DIR) \
+               --libdir=$(STAGING_DIR)/lib \
+               --includedir=$(STAGING_DIR)/include \
+       );
+       touch $(PKG_BUILD_DIR)/.configured
+
+$(PKG_BUILD_DIR)/$(PKG_NAME): $(PKG_BUILD_DIR)/.configured
+       $(MAKE) \
+               LDFLAGS="-L$(STAGING_DIR)/lib" \
+               LIBS="-lpcap" \
+               INCLS="-I. -I$(STAGING_DIR)/include" \
+               -C $(PKG_BUILD_DIR)
+
+$(PKG_IPK): $(PKG_BUILD_DIR)/$(PKG_NAME)
+       $(SCRIPT_DIR)/make-ipkg-dir.sh $(PKG_IPK_DIR) $(PKG_NAME).control $(PKG_VERSION)-$(PKG_RELEASE) $(ARCH)
+       mkdir -p $(PKG_IPK_DIR)/usr/sbin
+       cp $(PKG_BUILD_DIR)/$(PKG_NAME) $(PKG_IPK_DIR)/usr/sbin/
+       $(STRIP) $(PKG_IPK_DIR)/usr/sbin/*
+       mkdir -p $(PACKAGE_DIR)
+       $(IPKG_BUILD) $(PKG_IPK_DIR) $(PACKAGE_DIR)
+
+$(IPKG_STATE_DIR)/info/$(PKG_NAME).list: $(PKG_IPK)
+       $(IPKG) install $(PKG_IPK)
+
+source: $(DL_DIR)/$(PKG_SOURCE)
+prepare: $(PKG_BUILD_DIR)/.unpacked
+compile: $(PKG_IPK)
+install: $(IPKG_STATE_DIR)/info/$(PKG_NAME).list
+
+clean:
+       rm -rf $(PKG_BUILD_DIR)
+       rm -f $(PKG_IPK)
diff --git a/openwrt/package/tcpdump/tcpdump.control b/openwrt/package/tcpdump/tcpdump.control
new file mode 100644 (file)
index 0000000..6dd7047
--- /dev/null
@@ -0,0 +1,8 @@
+Package: tcpdump
+Priority: optional
+Section: net
+Version: 0.8.3-1
+Architecture: mipsel
+Maintainer: Felix Fietkau <nbd@vd-s.ath.cx>
+Source: buildroot internal
+Description: A tool for network monitoring and data acquisition.