python-contextlib2: Update to 21.6.0
authorJeffery To <jeffery.to@gmail.com>
Thu, 27 Jul 2023 18:16:26 +0000 (02:16 +0800)
committerTianling Shen <cnsztl@gmail.com>
Thu, 3 Aug 2023 17:58:19 +0000 (01:58 +0800)
Signed-off-by: Jeffery To <jeffery.to@gmail.com>
lang/python/python-contextlib2/Makefile

index df8d1ee9b5041f124446da6a19b142db08fa5317..dcbed11c2031dce51c9ba024564339147eac84e5 100644 (file)
@@ -5,12 +5,15 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=python-contextlib2
-PKG_VERSION:=0.6.0.post1
+PKG_VERSION:=21.6.0
 PKG_RELEASE:=1
-PKG_MAINTAINER:=Karel Kočí <cynerd@email.cz>
 
 PYPI_NAME:=contextlib2
-PKG_HASH:=01f490098c18b19d2bd5bb5dc445b2054d2fa97f09a4280ba2c5f3c394c8162e
+PKG_HASH:=ab1e2bfe1d01d968e1b7e8d9023bc51ef3509bba217bb730cee3827e1ee82869
+
+PKG_MAINTAINER:=Karel Kočí <cynerd@email.cz>
+PKG_LICENSE:=PSF-2.0 Apache-2.0
+PKG_LICENSE_FILES:=LICENSE.txt
 
 include ../pypi.mk
 include $(INCLUDE_DIR)/package.mk
@@ -20,13 +23,14 @@ define Package/python3-contextlib2
   SECTION:=lang
   CATEGORY:=Languages
   SUBMENU:=Python
-  URL:=http://contextlib2.readthedocs.org
-  TITLE:=python3-contextlib2
+  URL:=https://contextlib2.readthedocs.org
+  TITLE:=Backports and enhancements for the contextlib module
   DEPENDS:=+python3-light
 endef
 
 define Package/python-contextlib2/description
-  contextlib2 is a backport of the standard library’s contextlib module to earlier Python versions.
+contextlib2 is a backport of the standard library's contextlib module to
+earlier Python versions.
 endef
 
 $(eval $(call Py3Package,python3-contextlib2))