python-setuptools: Update to 68.2.2
authorJeffery To <jeffery.to@gmail.com>
Mon, 25 Sep 2023 16:38:11 +0000 (00:38 +0800)
committerRosen Penev <rosenp@gmail.com>
Wed, 27 Sep 2023 23:39:52 +0000 (16:39 -0700)
Signed-off-by: Jeffery To <jeffery.to@gmail.com>
lang/python/python-setuptools/Makefile
lang/python/python-setuptools/test.sh [new file with mode: 0644]

index 08cb7124fc1e51be7a6aadf417a84eecffe4a573..8138a9955648c3380e86b7fd47ab3f9b38f67de8 100644 (file)
@@ -8,11 +8,11 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=python-setuptools
-PKG_VERSION:=68.2.0
+PKG_VERSION:=68.2.2
 PKG_RELEASE:=1
 
 PYPI_NAME:=setuptools
-PKG_HASH:=00478ca80aeebeecb2f288d3206b0de568df5cd2b8fada1209843cc9a8d88a48
+PKG_HASH:=4ac1475276d2f1c48684874089fefcd83bd7162ddaafb81fac866ba0db282a87
 
 PKG_LICENSE:=MIT
 PKG_LICENSE_FILES:=LICENSE
diff --git a/lang/python/python-setuptools/test.sh b/lang/python/python-setuptools/test.sh
new file mode 100644 (file)
index 0000000..bc35600
--- /dev/null
@@ -0,0 +1,5 @@
+#!/bin/sh
+
+[ "$1" = python3-setuptools ] || exit 0
+
+python3 -c 'from setuptools import setup'