Merge pull request #7662 from neheb/lanes
authorHannu Nyman <hannu.nyman@iki.fi>
Thu, 27 Dec 2018 17:38:43 +0000 (19:38 +0200)
committerGitHub <noreply@github.com>
Thu, 27 Dec 2018 17:38:43 +0000 (19:38 +0200)
lualanes: Update to 3.13.0

lang/lualanes/Makefile
lang/lualanes/patches/100-musl-compat.patch
lang/lualanes/patches/200-fix-redef-error.patch [new file with mode: 0644]

index ca4573b4b54e5edfe072c0ba7a369fd95c1af60c..79bbc14f5c401cd1cd241b410c23382abdc1afe2 100644 (file)
@@ -8,16 +8,13 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=lualanes
-PKG_REV:=aa9bfcf2dd49f55f11b27e7c21d5b75d81ccfc7e
-PKG_VERSION:=3.9.4
-PKG_RELEASE=1
+PKG_VERSION:=3.13.0
+PKG_RELEASE:=1
 
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_REV).tar.gz
-PKG_MIRROR_HASH:=e9b053e627edaf7ef229af176177bf2bd0edd31b69690ba7c1e6be41041ffd07
-PKG_SOURCE_URL:=https://github.com/LuaLanes/lanes.git
-PKG_SOURCE_PROTO:=git
-PKG_SOURCE_VERSION:=$(PKG_REV)
-PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=https://codeload.github.com/LuaLanes/lanes/tar.gz/v$(PKG_VERSION)?
+PKG_HASH:=53a17d7ee11f17ca0543ae5aa640208dcb62d37862a0d0ea450455fae12c8ff1
+PKG_BUILD_DIR:=$(BUILD_DIR)/lanes-$(PKG_VERSION)
 
 PKG_INSTALL:=1
 PKG_BUILD_PARALLEL:=1
@@ -45,7 +42,7 @@ define Build/Compile
         CC="$(TARGET_CC)" \
         LUA="$(STAGING_DIR_HOSTPKG)/bin/lua" \
         LUAC="$(STAGING_DIR_HOSTPKG)/bin/luac" \
-        OPT_FLAGS="$(TARGET_CFLAGS) --std=c99 -Dpthread_yield=sched_yield"
+        OPT_FLAGS="$(TARGET_CFLAGS) -Dpthread_yield=sched_yield"
 endef
 
 define Package/lualanes/install
index ba3f49f9fe6fe6bc6cc6080cb591f843c16bcd41..2f3276b1f06fcd0cf4aa7855ed77a1e9c9486447 100644 (file)
@@ -1,8 +1,6 @@
-diff --git a/src/threading.h b/src/threading.h
-index bfa9ab8..7b3d6a1 100644
 --- a/src/threading.h
 +++ b/src/threading.h
-@@ -128,7 +128,7 @@ enum e_status { PENDING, RUNNING, WAITING, DONE, ERROR_ST, CANCELLED };
+@@ -110,7 +110,7 @@ enum e_status { PENDING, RUNNING, WAITING, DONE, ERROR_ST, CANCELLED };
    #endif // PLATFORM_WIN32
    #include <pthread.h>
  
diff --git a/lang/lualanes/patches/200-fix-redef-error.patch b/lang/lualanes/patches/200-fix-redef-error.patch
new file mode 100644 (file)
index 0000000..662e08f
--- /dev/null
@@ -0,0 +1,12 @@
+--- a/src/threading.c
++++ b/src/threading.c
+@@ -35,7 +35,9 @@ THE SOFTWARE.
+ ===============================================================================
+ */
+ #if defined(__linux__)
++#ifndef _GNU_SOURCE
+ # define _GNU_SOURCE /* must be defined before any include */
++#endif
+ # ifdef __ANDROID__
+ #  include <android/log.h>
+ #  define LOG_TAG "LuaLanes"