[package] broadcom-wl: fix broadcom (2.4) wireless sta (only) mode, adjust release...
authorNicolas Thill <nico@openwrt.org>
Mon, 1 Jun 2009 14:37:11 +0000 (14:37 +0000)
committerNicolas Thill <nico@openwrt.org>
Mon, 1 Jun 2009 14:37:11 +0000 (14:37 +0000)
This patch fixes an issue with the broadcom.sh configuration script when
enabling sta mode.  Currently sta mode works provided that you have an AP
enabled as well but it doesn't work if you have a sta interface but not an
AP.  I found that merely reversing the order of the ap and apsta variables
in the broadcom.sh script corrects this problem, and the attached patch does
exactly that.

Signed-off-by: Eric Bishop <ebishop@bu.edu>
SVN-Revision: 16256

package/broadcom-wl/Makefile
package/broadcom-wl/files/lib/wifi/broadcom.sh

index d33524f2c9834eef09ba6f972691b43df63bdb1a..cc0af0f69ec212e2d011334734209c23dcf78fdf 100644 (file)
@@ -10,7 +10,7 @@ include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=broadcom-wl
 PKG_VERSION:=4.150.10.5.3
-PKG_RELEASE:=3.2
+PKG_RELEASE:=3.1
 WLC_VERSION:=0.1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
index 9ce49ab6fbaddbbadc09b232fa9d0be8394929bf..7d56c10e00afc25dbcd732919debdb0438019ceb 100644 (file)
@@ -276,9 +276,9 @@ enable_broadcom() {
        wlc stdin <<EOF
 $ifdown
 
+apsta $apsta
 ap $ap
 ${mssid:+mssid $mssid}
-apsta $apsta
 infra $infra
 ${wet:+wet 1}
 802.11d 0