re: fix build errors on mipsel targets
authorSebastian Kemper <sebastian_ml@gmx.net>
Wed, 13 Dec 2017 18:29:01 +0000 (19:29 +0100)
committerSebastian Kemper <sebastian_ml@gmx.net>
Wed, 13 Dec 2017 18:29:06 +0000 (19:29 +0100)
On most mipsel targets re fails to build because the re Makefile adds
"-march=mips32" to CFLAGS:

Assembler messages:
Error: -mips32r2 conflicts with the other architecture options, which imply -mips32
src/sip/addr.c:1:0: error: '-mips32r2' conflicts with the other architecture options, which specify a mips32 processor
 /**
 ^
Makefile:92: recipe for target 'build-mipsel/sip/addr.o' failed

Fix this by preventing re from adding to OpenWrt CFLAGS.

Signed-off-by: Sebastian Kemper <sebastian_ml@gmx.net>
libs/re/patches/005-fix-builds-for-mipsel-targets.patch [new file with mode: 0644]

diff --git a/libs/re/patches/005-fix-builds-for-mipsel-targets.patch b/libs/re/patches/005-fix-builds-for-mipsel-targets.patch
new file mode 100644 (file)
index 0000000..64cebf5
--- /dev/null
@@ -0,0 +1,14 @@
+--- a/mk/re.mk
++++ b/mk/re.mk
+@@ -448,11 +448,6 @@ endif
+ CFLAGS        += -DARCH=\"$(ARCH)\"
+-ifeq ($(ARCH),mipsel)
+-CFLAGS += -march=mips32
+-endif
+-
+-
+ ##############################################################################
+ #
+ # External libraries section