[packages] weechat: Use pkg-config instead of gnutls-config
authorLars-Peter Clausen <lars@metafoo.de>
Wed, 17 Feb 2010 17:22:16 +0000 (17:22 +0000)
committerLars-Peter Clausen <lars@metafoo.de>
Wed, 17 Feb 2010 17:22:16 +0000 (17:22 +0000)
We don't ship gnutls-config and configure might end up using the hosts
gnutls-config.

SVN-Revision: 19690

net/weechat/Makefile
net/weechat/patches/010-use-pkg-config.patch [new file with mode: 0644]

index cf41d0e655f84732b51870568741e8708122d1ae..338997aa00d23f256a1fddeedf77eb4a5a4d79d1 100644 (file)
@@ -79,11 +79,11 @@ CONFIGURE_ARGS+= \
        --disable-python \
        --disable-ruby \
        LUACONFIG="" \
+       ac_cv_path_LIBGNUTLS_CONFIG="pkg-config gnutls" \
 
-CONFIGURE_VARS+= \
-       LDFLAGS="$$$$LDFLAGS -L$(STAGING_DIR)/usr/lib/libiconv/lib -Wl,-rpath-link,$(STAGING_DIR)/usr/lib" \
-
-TARGET_LDFLAGS += -lgnutls
+TARGET_LDFLAGS += \
+       -L$(STAGING_DIR)/usr/lib/libiconv/lib \
+       -Wl,-rpath-link,$(STAGING_DIR)/usr/lib
 
 ifneq ($(CONFIG_PACKAGE_weechat-mod-lua),)
   CONFIGURE_ARGS+= \
@@ -108,7 +108,7 @@ define Build/Compile
                all install
 endef
 
-define Package/weechat/install 
+define Package/weechat/install
        $(INSTALL_DIR) $(1)/usr/bin
        $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/weechat-curses $(1)/usr/bin/
        $(INSTALL_DIR) $(1)/usr/lib/weechat/plugins
@@ -116,7 +116,7 @@ endef
 
 define BuildPlugin
 
-  define Package/weechat-mod-$(1)/install      
+  define Package/weechat-mod-$(1)/install
        $(INSTALL_DIR) $$(1)/usr/lib/weechat/plugins
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/weechat/plugins/$(1).so* $$(1)/usr/lib/weechat/plugins/
   endef
diff --git a/net/weechat/patches/010-use-pkg-config.patch b/net/weechat/patches/010-use-pkg-config.patch
new file mode 100644 (file)
index 0000000..2fb3f16
--- /dev/null
@@ -0,0 +1,15 @@
+diff --git a/configure b/configure
+index f388ffe..c9ec352 100755
+--- a/configure
++++ b/configure
+@@ -31400,8 +31400,8 @@ echo "$as_me: WARNING:
+     if test "x$found_gnutls" = "xyes" ; then
+-        GNUTLS_CFLAGS=`libgnutls-config --cflags`
+-        GNUTLS_LFLAGS=`libgnutls-config --libs`
++        GNUTLS_CFLAGS=`pkg-config gnutls --cflags`
++        GNUTLS_LFLAGS=`pkg-config gnutls --libs`
+         cat >>confdefs.h <<\_ACEOF