librespeed-cli: rename binary to librespeed-cli
authorMichal Vasilek <michal.vasilek@nic.cz>
Mon, 21 Nov 2022 12:49:20 +0000 (13:49 +0100)
committerTianling Shen <cnsztl@gmail.com>
Mon, 21 Nov 2022 16:59:12 +0000 (00:59 +0800)
upstream names the binary librespeed-cli and this avoids a conflict with
python3-speedtest-cli

Signed-off-by: Michal Vasilek <michal.vasilek@nic.cz>
utils/librespeed-cli/Makefile

index b724b87548448d01294e5ffcd90c3e34c1ef894d..a816fdaecfbe4e3dc33045b908d7c52c81e43100 100644 (file)
@@ -41,5 +41,11 @@ define Package/librespeed-cli/description
   LibreSpeed client for measuring internet speed from command line.
 endef
 
+define Package/librespeed-cli/install
+       $(call GoPackage/Package/Install/Bin,$(PKG_INSTALL_DIR))
+       $(INSTALL_DIR) $(1)/usr/bin
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/speedtest-cli $(1)/usr/bin/librespeed-cli
+endef
+
 $(eval $(call GoBinPackage,librespeed-cli))
 $(eval $(call BuildPackage,librespeed-cli))