[packages_10.03.2] 6tunnel: merge r29809
authorJo-Philipp Wich <jow@openwrt.org>
Sun, 5 Feb 2012 03:22:16 +0000 (03:22 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Sun, 5 Feb 2012 03:22:16 +0000 (03:22 +0000)
SVN-Revision: 30171

ipv6/6tunnel/Makefile
ipv6/6tunnel/patches/100-arm-fix-optc-initialization.patch [new file with mode: 0644]

index 3ab60d6037fbd99684f0e28c6c060fa7413f8e1b..f864cd90500ade63573003424bf771416e6d3ba3 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2007 OpenWrt.org
+# Copyright (C) 2007-2012 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=6tunnel
 PKG_VERSION:=0.11rc2
-PKG_RELEASE:=2
+PKG_RELEASE:=3
 PKG_MD5SUM:=74e02d4f0704b3083a01feda66033449
 
 PKG_SOURCE_URL:=http://toxygen.net/6tunnel/
diff --git a/ipv6/6tunnel/patches/100-arm-fix-optc-initialization.patch b/ipv6/6tunnel/patches/100-arm-fix-optc-initialization.patch
new file mode 100644 (file)
index 0000000..e84da61
--- /dev/null
@@ -0,0 +1,11 @@
+--- a/6tunnel.c
++++ b/6tunnel.c
+@@ -508,7 +508,7 @@ int main(int argc, char **argv)
+ {
+       int force = 0, lsock, csock, one = 0, jeden = 1, local_port;
+       int detach = 1, listen6 = 0, sa_len, conn_limit = 0;
+-      char optc, *username = NULL, *bind_host = NULL;
++      char optc = -1, *username = NULL, *bind_host = NULL;
+       struct sockaddr *sa;
+       struct sockaddr_in laddr, caddr;
+       struct sockaddr_in6 laddr6;