transmission: add a bunch of syscalls to seccomp filter
authorDaniel Golle <daniel@makrotopia.org>
Sat, 20 Nov 2021 11:55:01 +0000 (11:55 +0000)
committerDaniel Golle <daniel@makrotopia.org>
Sat, 20 Nov 2021 11:57:10 +0000 (11:57 +0000)
Add missing "inotify_add_watch", "inotify_init1" and "inotify_rm_watch"
syscalls to seccomp filter which are needed in case watch_dir feature
of transmission is used.

Fixes #16972
Reported-by: @siwind
Signed-off-by: Daniel Golle <daniel@makrotopia.org>
net/transmission/Makefile
net/transmission/files/transmission-daemon.json

index 8c1e6106132f4e177f01323e543222eec4ff33d2..7434dd4ba319057e605ccdef03977b1a3b4b6d0d 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=transmission
 PKG_VERSION:=3.00
-PKG_RELEASE:=15
+PKG_RELEASE:=16
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=@GITHUB/transmission/transmission-releases/master
index 41c3a7d865300752f8071ee82a917979f0d1c242..b652d325744b8eaf756f4eed9a79a7be7da7838b 100644 (file)
@@ -42,6 +42,9 @@
                                "getsockopt",
                                "getuid",
                                "getuid32",
+                               "inotify_add_watch",
+                               "inotify_init1",
+                               "inotify_rm_watch",
                                "ioctl",
                                "listen",
                                "_llseek",