Merge pull request #19985 from stangri/master-https-dns-proxy
authorStan Grishin <stangri@melmac.ca>
Tue, 29 Nov 2022 21:40:53 +0000 (14:40 -0700)
committerGitHub <noreply@github.com>
Tue, 29 Nov 2022 21:40:53 +0000 (14:40 -0700)
https-dns-proxy: improve performance on restart

net/https-dns-proxy/Makefile
net/https-dns-proxy/files/https-dns-proxy.init

index ed2e4677e619ebbe14b2da2424764953474bba09..81b01e5b90af5c0df55cae1db64e8d60bda6a661 100644 (file)
@@ -2,7 +2,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=https-dns-proxy
 PKG_VERSION:=2022-10-15
-PKG_RELEASE:=7
+PKG_RELEASE:=8
 
 PKG_SOURCE_PROTO:=git
 PKG_SOURCE_URL:=https://github.com/aarond10/https_dns_proxy/
index 4f09065602f7961d436dba2d75cd88c6fca82e45..cae80f161ef3a8a1d44bb053cf885883d42c0b9d 100755 (executable)
@@ -279,6 +279,7 @@ service_triggers() {
 
 service_started() { procd_set_config_changed firewall; }
 service_stopped() { procd_set_config_changed firewall; }
+restart() { procd_send_signal "$packageName"; }
 
 dnsmasq_doh_server() {
        local cfg="$1" param="$2" address="${3:-127.0.0.1}" port="$4" i