Merge pull request #18091 from c---/fixcurlwolfssl
authorStan Grishin <stangri@melmac.ca>
Fri, 18 Mar 2022 16:38:32 +0000 (09:38 -0700)
committerGitHub <noreply@github.com>
Fri, 18 Mar 2022 16:38:32 +0000 (09:38 -0700)
curl: Fix compiling curl wolfSSL when IPv6 is disabled

lang/python/Mako/Makefile [deleted file]
libs/expat/Makefile
libs/glib2/Makefile
libs/glib2/patches-host/001-musl-libintl.patch [new file with mode: 0644]
net/bind/Makefile

diff --git a/lang/python/Mako/Makefile b/lang/python/Mako/Makefile
deleted file mode 100644 (file)
index cad511a..0000000
+++ /dev/null
@@ -1,48 +0,0 @@
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=Mako
-PKG_VERSION:=1.1.5
-PKG_RELEASE:=1
-
-PYPI_NAME:=$(PKG_NAME)
-PKG_HASH:=169fa52af22a91900d852e937400e79f535496191c63712e3b9fda5a9bed6fc3
-
-PKG_MAINTAINER:=Daniel Golle <daniel@makrotopia.org>
-PKG_LICENSE:=BSD-3-Clause
-PKG_LICENSE_FILES:=LICENSE.rst
-PKG_CPE_ID:=cpe:/a:palletsprojects:flask
-
-HOST_BUILD_DEPENDS:=python3/host
-
-include ../pypi.mk
-include $(INCLUDE_DIR)/host-build.mk
-include $(INCLUDE_DIR)/package.mk
-include ../python3-package.mk
-
-define Package/python3-mako
-  SECTION:=lang
-  CATEGORY:=Languages
-  SUBMENU:=Python
-  TITLE:=Mako
-  URL:=https://www.makotemplates.org/
-  DEPENDS:=+python3-light
-endef
-
-define Package/python3-mako/description
- Mako is a template library written in Python.
-endef
-
-define Host/Compile
-       $(call HostPython3/ModSetup,,install --prefix="" --root="$(STAGING_DIR_HOSTPKG)")
-endef
-
-Host/Install:=
-
-$(eval $(call Py3Package,python3-mako))
-$(eval $(call BuildPackage,python3-mako))
-$(eval $(call BuildPackage,python3-mako-src))
-$(eval $(call HostBuild))
index 63a867e1a5b5e3a8bcecf0f8e8202fab1767469a..e41d6fd4206ff76c040d879265d1b261537b9631 100644 (file)
@@ -21,7 +21,6 @@ PKG_CPE_ID:=cpe:/a:libexpat:expat
 CMAKE_INSTALL:=1
 
 include $(INCLUDE_DIR)/package.mk
-include $(INCLUDE_DIR)/host-build.mk
 include $(INCLUDE_DIR)/cmake.mk
 
 define Package/libexpat
@@ -52,5 +51,4 @@ define Package/libexpat/install
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/libexpat.so.* $(1)/usr/lib/
 endef
 
-$(eval $(call HostBuild))
 $(eval $(call BuildPackage,libexpat))
index d6256e64272f349033ac2f59b949877ffcebaa49..0393fef20b858426a1a375747c5d02db18af8b0b 100644 (file)
@@ -27,6 +27,8 @@ HOST_BUILD_DEPENDS:=libiconv/host libffi/host pcre/host
 PKG_CONFIG_DEPENDS:=CONFIG_BUILD_NLS
 PKG_INSTALL:=1
 
+HOST_PATCH_DIR:=./patches-host
+
 include $(INCLUDE_DIR)/host-build.mk
 include $(INCLUDE_DIR)/package.mk
 include $(INCLUDE_DIR)/nls.mk
@@ -44,7 +46,6 @@ define Package/glib2/description
   The GLib library of C routines
 endef
 
-HOST_LDFLAGS += -Wl,-rpath,$(STAGING_DIR_HOSTPKG)/lib
 TARGET_CFLAGS += -ffunction-sections -fdata-sections
 TARGET_LDFLAGS += -Wl,--gc-sections $(if $(INTL_FULL),-lintl)
 
diff --git a/libs/glib2/patches-host/001-musl-libintl.patch b/libs/glib2/patches-host/001-musl-libintl.patch
new file mode 100644 (file)
index 0000000..db224f5
--- /dev/null
@@ -0,0 +1,20 @@
+--- a/meson.build
++++ b/meson.build
+@@ -2047,9 +2047,6 @@ endif
+ # FIXME: glib-gettext.m4 has much more checks to detect broken/uncompatible
+ # implementations. This could be extended if issues are found in some platforms.
+ libintl_deps = []
+-if cc.has_function('ngettext', args : osx_ldflags)
+-  have_bind_textdomain_codeset = cc.has_function('bind_textdomain_codeset')
+-else
+   # First just find the bare library.
+   libintl = cc.find_library('intl', required : false)
+   # The bare library probably won't link without help if it's static.
+@@ -2081,7 +2078,6 @@ else
+     have_bind_textdomain_codeset = cc.has_function('bind_textdomain_codeset', args : osx_ldflags,
+                                                    dependencies : libintl_deps)
+   endif
+-endif
+ glib_conf.set('HAVE_BIND_TEXTDOMAIN_CODESET', have_bind_textdomain_codeset)
index 8dbf15cfe4a6ecf60c8b4f800ba0d792ebf98da7..f6065d49f472934abca4c2abcc704784d5d71ef4 100644 (file)
@@ -9,7 +9,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=bind
-PKG_VERSION:=9.18.0
+PKG_VERSION:=9.18.1
 PKG_RELEASE:=$(AUTORELEASE)
 USERID:=bind=57:bind=57
 
@@ -22,7 +22,7 @@ PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:= \
        https://www.mirrorservice.org/sites/ftp.isc.org/isc/bind9/$(PKG_VERSION) \
        https://ftp.isc.org/isc/bind9/$(PKG_VERSION)
-PKG_HASH:=56525bf5caf01fd8fd9d90910880cc0f8a90a27a97d169187d651d4ecf0c411c
+PKG_HASH:=57c7afd871694d615cb4defb1c1bd6ed023350943d7458414db8d493ef560427
 
 PKG_FIXUP:=autoreconf
 PKG_REMOVE_FILES:=aclocal.m4 libtool.m4