Added vrrpd package, fixed typo in vgp Config.in and added them to the package list...
authorFlorian Fainelli <florian@openwrt.org>
Mon, 12 Dec 2005 22:44:19 +0000 (22:44 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Mon, 12 Dec 2005 22:44:19 +0000 (22:44 +0000)
SVN-Revision: 2644

openwrt/package/Config.in
openwrt/package/Makefile
openwrt/package/vgp/Config.in
openwrt/package/vrrpd/Config.in [new file with mode: 0755]
openwrt/package/vrrpd/Makefile [new file with mode: 0755]
openwrt/package/vrrpd/ipkg/vrrpd.control [new file with mode: 0755]
openwrt/package/vrrpd/patches/01-honor-target_cc.patch [new file with mode: 0644]

index c606055560b9a7625b4481e65059aeeee332e219..bd5bb67f88fdd5ae1548fdc4bf85df02de878a60 100644 (file)
@@ -129,6 +129,8 @@ source "package/tor/Config.in"
 source "package/ttcp/Config.in"
 source "package/ulogd/Config.in"
 source "package/updatedd/Config.in"
+source "package/vgp/Config.in"
+source "package/vrrpd/Config.in"
 source "package/vsftpd/Config.in"
 source "package/vtun/Config.in"
 source "package/wificonf/Config.in"
index 7168c3f557dbd4dc0182e067910626b48d598505..ea902e4aac6fdff47eb98eee27ef3d43fc19052c 100644 (file)
@@ -205,6 +205,8 @@ package-$(BR2_COMPILE_USBUTILS) += usbutils
 package-$(BR2_PACKAGE_USTL) += ustl
 package-$(BR2_COMPILE_UTIL_LINUX) += util-linux
 package-$(BR2_PACKAGE_UDEV) += udev
+package-$(BR2_PACKAGE_VGP) += vgp
+package-$(BR2_PACKGE_VRRPD) += vrrpd
 package-$(BR2_PACKAGE_VTUN) += vtun
 package-$(BR2_PACKAGE_VSFTPD) += vsftpd
 package-$(BR2_PACKAGE_WIFICONF) += wificonf
index ace8446a4960323d23fb6142538ba4154f0aef44..b3426846cf9161de690593e1200a191a775fd980 100755 (executable)
@@ -1,11 +1,7 @@
 config BR2_PACKAGE_VGP
-       tristate "vgp - a daemon working like Cisco(c) HSRP"
+       tristate "vgp............................... a daemon working like Cisco(c) HSRP"
        default m if CONFIG_DEVEL
        help
                VGP (Virtual Gateway Protocol)is a very simple protocol able to work in 
-  a way similar to Cisco(c) HSRP. It implements the idea of Virtual Gateway
-  to provide fault tollerance (and load balancing) on your net. 
-  Each client on your net has as its default gateway the virtual gateway 
-  and not the real router. 
-               
-               http://vgpd.freaknet.org/
\ No newline at end of file
+               a way similar to Cisco(c) HSRP. It implements the idea of Virtual Gateway to provide fault tollerance (and load balancing) on your net. Each client on your net has as its default gateway the virtual gateway and not the real router.
+               http://vgpd.freaknet.org/
diff --git a/openwrt/package/vrrpd/Config.in b/openwrt/package/vrrpd/Config.in
new file mode 100755 (executable)
index 0000000..84e7dbc
--- /dev/null
@@ -0,0 +1,8 @@
+config BR2_PACKAGE_VRRPD
+        tristate "vrrpd............................. Virtual Router Redundancy Protocol daemon"
+       default m if CONFIG_DEVEL
+       help
+               VRRPd is an implementation of Virtual Router Redundancy Protocol as specified in rfc2338. 
+               VRRPd is interoperable with other RFC-based VRRP implementations, including Cisco and Juniper, and is included as a standard feature on ImageStream routers.
+               
+               http://www.sourceforge.net/projects/vrrpd
diff --git a/openwrt/package/vrrpd/Makefile b/openwrt/package/vrrpd/Makefile
new file mode 100755 (executable)
index 0000000..82ee36b
--- /dev/null
@@ -0,0 +1,33 @@
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=vrrpd
+PKG_VERSION:=1.0
+PKG_RELEASE:=1
+
+PKG_MD5SUM:=6d5066ea1a6ced817376ca0f54765447
+PKG_SOURCE_URL:=@SF/vrrpd
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+PKG_CAT:=zcat
+
+PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+
+include $(TOPDIR)/package/rules.mk
+
+$(eval $(call PKG_template,VRRPD,VRRPD,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
+
+$(PKG_BUILD_DIR)/.configured:
+       touch $@
+
+$(PKG_BUILD_DIR)/.built:
+       mkdir -p $(PKG_INSTALL_DIR)/usr/sbin
+       $(MAKE) CC=$(TARGET_CC) -C $(PKG_BUILD_DIR)
+       install -m0755 $(PKG_BUILD_DIR)/vrrpd $(PKG_INSTALL_DIR)/usr/sbin/
+       touch $@
+
+$(IPKG_VRRPD):
+       mkdir -p $(IDIR_VRRPD)
+       cp -fpR $(PKG_INSTALL_DIR)/* $(IDIR_VRRPD)/
+       $(RSTRIP) $(IDIR_VRRPD)
+       $(IPKG_BUILD) $(IDIR_VRRPD) $(PACKAGE_DIR)
diff --git a/openwrt/package/vrrpd/ipkg/vrrpd.control b/openwrt/package/vrrpd/ipkg/vrrpd.control
new file mode 100755 (executable)
index 0000000..92cce30
--- /dev/null
@@ -0,0 +1,5 @@
+Package: vrrpd
+Section: net
+Architecture: mipsel
+Priority: optional
+Description: VRRPd is an implementation of Virtual Router Redundancy Protocol as specified in rfc2338.
diff --git a/openwrt/package/vrrpd/patches/01-honor-target_cc.patch b/openwrt/package/vrrpd/patches/01-honor-target_cc.patch
new file mode 100644 (file)
index 0000000..c750607
--- /dev/null
@@ -0,0 +1,11 @@
+diff -urN orig/vrrpd-1.0/Makefile vrrpd-1.0/Makefile
+--- orig/vrrpd-1.0/Makefile    2002-09-09 16:51:13.000000000 +0200
++++ vrrpd-1.0/Makefile 2005-12-12 23:31:30.000000000 +0100
+@@ -15,7 +15,6 @@
+ COMMON_CFLAGS= $(MAIN_OPT) $(INCLUDEOPT) $(PROF_OPT) $(DBG_OPT) $(MACHINEOPT)
+ # set to compile with GCC
+-CC=gcc
+ CFLAGS= $(COMMON_CFLAGS) -Wall
+ vrrpd : $(VRRPD_OBJS)