sqlite3: remove $(FPIC) 7725/head
authorSebastian Kemper <sebastian_ml@gmx.net>
Tue, 18 Dec 2018 19:53:12 +0000 (20:53 +0100)
committerSebastian Kemper <sebastian_ml@gmx.net>
Tue, 18 Dec 2018 19:57:47 +0000 (20:57 +0100)
Defaulting to -fPIC is a bad idea, especially for executables (here:
sqlite3-cli). In short, there are certain security implications as well
as overhead/performance penalties. Details see:

https://wiki.gentoo.org/wiki/Project:Hardened/Position_Independent_Code_internals

The configure script is able to detect the need for PIC and adds the
flag when needed anyway (when compiling the library).

Signed-off-by: Sebastian Kemper <sebastian_ml@gmx.net>
libs/sqlite3/Makefile

index 28020e3a286a596905ec0b5da457c5a44da4d610..71be4e1893bd52c5653ec1e9fd3c4345e6374570 100644 (file)
@@ -75,7 +75,7 @@ $(call Package/sqlite3/Default/description)
  formats.
 endef
 
-TARGET_CFLAGS += $(FPIC) \
+TARGET_CFLAGS += \
        -DSQLITE_ENABLE_UNLOCK_NOTIFY=1 \
        -DHAVE_ISNAN=1 \
        -DHAVE_MALLOC_USABLE_SIZE=1