liblo: import from old packages feed 229/head
authorNicolas Thill <nico@openwrt.org>
Wed, 20 Aug 2014 12:54:46 +0000 (14:54 +0200)
committerNicolas Thill <nico@openwrt.org>
Wed, 20 Aug 2014 13:52:06 +0000 (15:52 +0200)
 - update to latest version (v0.28)
 - add license info
 - add myself as maintainer

Signed-off-by: Nicolas Thill <nico@openwrt.org>
libs/liblo/Makefile [new file with mode: 0644]

diff --git a/libs/liblo/Makefile b/libs/liblo/Makefile
new file mode 100644 (file)
index 0000000..4ab9ad7
--- /dev/null
@@ -0,0 +1,71 @@
+#
+# Copyright (C) 2010-2014 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=liblo
+PKG_VERSION:=0.28
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=@SF/liblo
+PKG_MD5SUM:=e2a4391a08b49bb316c03e2034e06fa2
+
+PKG_LICENSE:=LGPL-2.1+
+PKG_LICENSE_FILE:=COPYING
+PKG_MAINTAINER:=Nicolas Thill <nico@openwrt.org>
+
+PKG_INSTALL:=1
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/liblo/Default
+  SUBMENU:=Sound
+  TITLE:=Lightweight Open Sound Control (OSC)
+  URL:=http://liblo.sourceforge.net/
+endef
+
+define Package/liblo
+$(call Package/liblo/Default)
+  SECTION:=libs
+  CATEGORY:=Libraries
+  TITLE+= library
+  DEPENDS:= +libpthread
+endef
+
+define Package/liblo-utils
+$(call Package/liblo/Default)
+  SECTION:=utils
+  CATEGORY:=Utilities
+  TITLE+= utilities
+  DEPENDS:= +liblo
+endef
+
+TARGET_CFLAGS += \
+       -Wno-error=maybe-uninitialized \
+
+define Build/InstallDev
+       $(INSTALL_DIR) $(1)/usr/include
+       $(CP) $(PKG_INSTALL_DIR)/usr/include/lo $(1)/usr/include/
+       $(INSTALL_DIR) $(1)/usr/lib
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/liblo.* $(1)/usr/lib/
+       $(INSTALL_DIR) $(1)/usr/lib/pkgconfig
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/liblo.pc $(1)/usr/lib/pkgconfig/
+endef
+
+define Package/liblo/install
+       $(INSTALL_DIR) $(1)/usr/lib
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/liblo.so.* $(1)/usr/lib/
+endef
+
+define Package/liblo-utils/install
+       $(INSTALL_DIR) $(1)/usr/bin
+       $(CP) $(PKG_INSTALL_DIR)/usr/bin/osc{dump,send} $(1)/usr/bin/
+endef
+
+$(eval $(call BuildPackage,liblo))
+$(eval $(call BuildPackage,liblo-utils))