mariadb: add dependency on libaio for arc as well 9302/head
authorSebastian Kemper <sebastian_ml@gmx.net>
Mon, 24 Jun 2019 08:36:20 +0000 (10:36 +0200)
committerSebastian Kemper <sebastian_ml@gmx.net>
Mon, 24 Jun 2019 08:38:25 +0000 (10:38 +0200)
Now that libaio compiles on arc targets we need to add the dependency to
libaio on these targets as well.

resolves #9298

Signed-off-by: Sebastian Kemper <sebastian_ml@gmx.net>
utils/mariadb/Makefile

index fead55294452438ddff6517492b05d96aadc9e78..8ae1ad09efb8f3b243645bc958c148efaceb5ab9 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=mariadb
 PKG_VERSION:=10.2.24
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL := \
@@ -327,7 +327,7 @@ define Package/mariadb-server-base
   $(call Package/mariadb/Default)
   DEPENDS:=mariadb-common \
          $(MARIADB_COMMON_DEPENDS_EXE) \
-         +!arc:libaio \
+         +libaio \
          +liblzma \
          +libpcre \
          +resolveip