znc: update to 1.9.0
authorJonas Gorski <jonas.gorski@gmail.com>
Sun, 12 May 2024 12:42:22 +0000 (14:42 +0200)
committerJonas Gorski <jonas.gorski@gmail.com>
Sun, 12 May 2024 12:42:43 +0000 (14:42 +0200)
Update ZNC to 1.9.0 with the following changes:

* drop all patches:
  * 101-Reduce_rebuild_time.patch was only applicable for the old
    autoconf build, which was dropped in 1.9 and we didn't use anymore
    anyway
  * 104-disable-empty-modules-check.patch not needed anymore since ZNC
    now requires the new corecaps module on startup
  * 120-openssl-deprecated.patch was applied upstream
* disable libargon2 support explicitly to avoid non-deterministic builds
  if it gets added
* package new module corecaps with znc base, as this is a required
  module
* reorder CMAKE_OPTIONS alphabetically

No new modules were introduced or removed besides the new corecaps
module.

Signed-off-by: Jonas Gorski <jonas.gorski@gmail.com>
net/znc/Makefile
net/znc/patches/101-Reduce_rebuild_time.patch [deleted file]
net/znc/patches/104-disable-empty-modules-check.patch [deleted file]
net/znc/patches/120-openssl-deprecated.patch [deleted file]

index e2528909d3da390859eeb77ff4b4ee63a14b2f05..9111209e68c30ce48dedd6fb6c1ffcf05dc22990 100644 (file)
@@ -8,13 +8,13 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=znc
-PKG_VERSION:=1.8.2
-PKG_RELEASE:=6
+PKG_VERSION:=1.9.0
+PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=https://znc.in/releases \
                https://znc.in/releases/archive
-PKG_HASH:=ff238aae3f2ae0e44e683c4aee17dc8e4fdd261ca9379d83b48a7d422488de0d
+PKG_HASH:=8b99c9dbb21c1309705073460be9bfacb6f7b0e83a15fe5d4b7140201b39d2a1
 
 PKG_MAINTAINER:=Jonas Gorski <jonas.gorski@gmail.com>
 PKG_LICENSE:=Apache-2.0
@@ -58,6 +58,8 @@ endef
 define Package/znc/install
        $(INSTALL_DIR) $(1)/usr/bin
        $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/znc $(1)/usr/bin/
+       $(INSTALL_DIR) $(1)/usr/lib/znc
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/lib/znc/corecaps.so $(1)/usr/lib/znc/
        $(INSTALL_DIR) $(1)/etc/init.d
        $(INSTALL_BIN) ./files/znc.init $(1)/etc/init.d/znc
        $(INSTALL_DIR) $(1)/etc/config
@@ -346,14 +348,15 @@ include $(INCLUDE_DIR)/package.mk
 include $(INCLUDE_DIR)/cmake.mk
 
 CMAKE_OPTIONS += \
-       -DWANT_ICU=O$(if $(CONFIG_ZNC_ICU),N,FF) \
+       -DWANT_ARGON=OFF \
        -DWANT_I18N=OFF \
+       -DWANT_ICU=O$(if $(CONFIG_ZNC_ICU),N,FF) \
        -DWANT_CYRUS=OFF \
+       -DWANT_OPENSSL=ON \
        -DWANT_PERL=OFF \
-       -DWANT_SYSTEMD=OFF \
        -DWANT_PYTHON=OFF \
-       -DWANT_OPENSSL=ON \
        -DWANT_SWIG=OFF \
+       -DWANT_SYSTEMD=OFF \
        -DWANT_TCL=OFF \
        -DWANT_ZLIB=ON
 
diff --git a/net/znc/patches/101-Reduce_rebuild_time.patch b/net/znc/patches/101-Reduce_rebuild_time.patch
deleted file mode 100644 (file)
index 6282482..0000000
+++ /dev/null
@@ -1,39 +0,0 @@
-From 0527869a72c27bfb25b5f92fdd77a04c39d939db Mon Sep 17 00:00:00 2001
-From: Jonas Gorski <jonas.gorski+openwrt@gmail.com>
-Date: Sat, 16 Apr 2011 05:51:04 +0200
-Subject: [PATCH] Don't rebuild everything when the Makefile's timestamp
- changed
-
----
- Makefile.in         | 2 +-
- modules/Makefile.in | 4 ++--
- 2 files changed, 3 insertions(+), 3 deletions(-)
-
---- a/Makefile.in
-+++ b/Makefile.in
-@@ -128,7 +128,7 @@ clean:
- distclean: clean
-       rm -rf $(DISTCLEAN)
--src/%.o: src/%.cpp Makefile include/znc/Csocket.h
-+src/%.o: src/%.cpp include/znc/Csocket.h
-       @mkdir -p .depend src
-       $(E) Building core object $*...
-       $(Q)$(CXX) $(CXXFLAGS) -c -o $@ $< -MD -MF .depend/$*.dep -MT $@
---- a/modules/Makefile.in
-+++ b/modules/Makefile.in
-@@ -127,12 +127,12 @@ install_datadir:
- clean:
-       rm -rf $(CLEAN)
--%.o: %.cpp Makefile
-+%.o: %.cpp
-       @mkdir -p .depend
-       $(E) Building module $(notdir $(basename $@))...
-       $(Q)$(CXX) $(MODFLAGS) -c -o $@ $< $($(notdir $(basename $@))CXXFLAGS) -MD -MF .depend/$(notdir $@).dep
--%.so: %.o Makefile
-+%.so: %.o
-       $(E) "Linking  module" $(notdir $(basename $@))...
-       $(Q)$(CXX) $(MODFLAGS) $(LDFLAGS) $(MODLINK) -o $@ $< $($(notdir $(basename $@))LDFLAGS) $(LIBS)
diff --git a/net/znc/patches/104-disable-empty-modules-check.patch b/net/znc/patches/104-disable-empty-modules-check.patch
deleted file mode 100644 (file)
index ea62472..0000000
+++ /dev/null
@@ -1,17 +0,0 @@
---- a/src/main.cpp
-+++ b/src/main.cpp
-@@ -422,12 +422,14 @@ int main(int argc, char** argv) {
-                 "No modules found. Perhaps you didn't install ZNC properly?");
-             CUtils::PrintError(
-                 "Read https://wiki.znc.in/Installation for instructions.");
-+#if 0
-             if (!CUtils::GetBoolInput(
-                     "Do you really want to run ZNC without any modules?",
-                     false)) {
-                 CZNC::DestroyInstance();
-                 return 1;
-             }
-+#endif
-         }
-         CUtils::PrintStatus(true, "");
-     }
diff --git a/net/znc/patches/120-openssl-deprecated.patch b/net/znc/patches/120-openssl-deprecated.patch
deleted file mode 100644 (file)
index c6ee5bb..0000000
+++ /dev/null
@@ -1,56 +0,0 @@
---- a/third_party/Csocket/Csocket.cc
-+++ b/third_party/Csocket/Csocket.cc
-@@ -47,10 +47,16 @@
- #include <stdio.h>
- #include <openssl/ssl.h>
- #include <openssl/conf.h>
--#include <openssl/engine.h>
-+#include <openssl/bn.h>
-+#include <openssl/dh.h>
-+#include <openssl/dsa.h>
-+#include <openssl/rsa.h>
- #ifndef OPENSSL_NO_COMP
- #include <openssl/comp.h>
- #endif
-+#ifndef OPENSSL_NO_ENGINE
-+#include <openssl/engine.h>
-+#endif
- #define HAVE_ERR_REMOVE_STATE
- #ifdef OPENSSL_VERSION_NUMBER
- # if OPENSSL_VERSION_NUMBER >= 0x10000000
-@@ -588,15 +594,17 @@ void ShutdownCsocket()
- #elif defined( HAVE_ERR_REMOVE_STATE )
-       ERR_remove_state( 0 );
- #endif
--#ifndef OPENSSL_NO_ENGINE
--      ENGINE_cleanup();
--#endif
- #ifndef OPENSSL_IS_BORINGSSL
-       CONF_modules_unload( 1 );
- #endif
-+#if OPENSSL_VERSION_NUMBER < 0x10100000L
-+#ifndef OPENSSL_NO_ENGINE
-+      ENGINE_cleanup();
-+#endif
-       ERR_free_strings();
-       EVP_cleanup();
-       CRYPTO_cleanup_all_ex_data();
-+#endif
- #endif /* HAVE_LIBSSL */
- #ifdef HAVE_C_ARES
- #if ARES_VERSION >= CREATE_ARES_VER( 1, 6, 1 )
-@@ -611,12 +619,14 @@ void ShutdownCsocket()
- #ifdef HAVE_LIBSSL
- bool InitSSL( ECompType eCompressionType )
- {
-+#if OPENSSL_VERSION_NUMBER < 0x10100000L
-       SSL_load_error_strings();
-       if( SSL_library_init() != 1 )
-       {
-               CS_DEBUG( "SSL_library_init() failed!" );
-               return( false );
-       }
-+#endif
- #ifndef _WIN32
-       if( access( "/dev/urandom", R_OK ) == 0 )