sockread: add missing header
authorRosen Penev <rosenp@gmail.com>
Sun, 30 Jan 2022 03:51:31 +0000 (19:51 -0800)
committerRosen Penev <rosenp@gmail.com>
Mon, 31 Jan 2022 15:05:17 +0000 (07:05 -0800)
Needed for memset, memcpy, and strerror.

Signed-off-by: Rosen Penev <rosenp@gmail.com>
utils/sockread/Makefile
utils/sockread/src/main.c

index d3c15d468a0079acffd6b73505dabf4898d19ad1..52daf82b1fec096ad22ec9c73dce38ae768c0374 100644 (file)
@@ -5,7 +5,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=sockread
 PKG_VERSION:=1.0
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 PKG_LICENSE:=CC0-1.0
 
 include $(INCLUDE_DIR)/package.mk
index 06c21def4dbcb7234fa72f35fb118cbb410db2cd..c685bce71b89ce4eb9f9156bca6596f74bb85812 100644 (file)
@@ -1,4 +1,4 @@
-
+#include <string.h>
 #include <stdio.h>
 #include <stdlib.h>
 #include <errno.h>