ramips: remove kmod-mt7663-firmware-sta from device packages
authorFelix Fietkau <nbd@nbd.name>
Sun, 17 Oct 2021 14:05:34 +0000 (16:05 +0200)
committerPaul Spooren <mail@aparcar.org>
Wed, 23 Mar 2022 12:52:20 +0000 (12:52 +0000)
This firmware should only be used for mobile devices (e.g. laptops), where
AP mode functionality is typically not used. This firmware supports a lot
of power saving offload functionality at the expense of AP mode support.

Signed-off-by: Felix Fietkau <nbd@nbd.name>
(cherry picked from commit a1ac8728f80314c574201013e7fea58536c2b3ee)

target/linux/ramips/image/mt7621.mk

index a3bc14d59d9923aac77be2f76a2289c05282259e..8ee2a020bb24c616a18cedf2cb8c3b5dfe2f8fc9 100644 (file)
@@ -803,7 +803,7 @@ define Device/linksys_e5600
   DEVICE_VENDOR := Linksys
   DEVICE_MODEL := E5600
   DEVICE_PACKAGES := kmod-mt7603 kmod-mt7615e kmod-mt7663-firmware-ap \
-       kmod-mt7663-firmware-sta uboot-envtools
+       uboot-envtools
   UBINIZE_OPTS := -E 5
   IMAGES += factory.bin
   IMAGE/sysupgrade.bin := sysupgrade-tar | check-size | append-metadata
@@ -1237,7 +1237,7 @@ define Device/tplink_archer-a6-v3
   DEVICE_MODEL := Archer A6
   DEVICE_VARIANT := V3
   DEVICE_PACKAGES := kmod-mt7603 kmod-mt7615e \
-       kmod-mt7663-firmware-ap kmod-mt7663-firmware-sta
+       kmod-mt7663-firmware-ap
   TPLINK_BOARD_ID := ARCHER-A6-V3
   KERNEL := $(KERNEL_DTB) | uImage lzma
   IMAGE_SIZE := 15744k