new package - aria2
authorJo-Philipp Wich <jow@openwrt.org>
Tue, 24 Jan 2012 14:19:14 +0000 (14:19 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Tue, 24 Jan 2012 14:19:14 +0000 (14:19 +0000)
aria2 is a lightweight multi-protocol & multi-source download utility
operated in command-line. It supports HTTP/HTTPS, FTP, BitTorrent
and Metalink. aria2 has built-in JSON-RPC and XML-RPC interface.

Signed-off-by: Cezary Jackiewicz <cezary.jackiewicz@gmail.com>
SVN-Revision: 29887

packages/net/aria2/Makefile [new file with mode: 0644]

diff --git a/packages/net/aria2/Makefile b/packages/net/aria2/Makefile
new file mode 100644 (file)
index 0000000..8db2cf7
--- /dev/null
@@ -0,0 +1,57 @@
+#
+# Copyright (C) 2012 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=aria2
+PKG_VERSION:=1.14.1
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
+PKG_SOURCE_URL:=@SF/aria2
+PKG_MD5SUM:=3a23844ab3e1460eb7e6dac9b5dd798c
+PKG_INSTALL:=1
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/aria2
+  SECTION:=net
+  CATEGORY:=Network
+  TITLE:=Lightweight download utility
+  URL:=http://aria2.sourceforge.net/
+  DEPENDS:=+libopenssl +zlib +libxml2 +libstdcpp \
+       $(INTL_DEPENDS) $(ICONV_DEPENDS)
+endef
+
+define Package/aria2/description
+ aria2 is a lightweight multi-protocol & multi-source download utility 
+ operated in command-line. It supports HTTP/HTTPS, FTP, BitTorrent and 
+ Metalink. aria2 has built-in JSON-RPC and XML-RPC interface. You can 
+ manipulate aria2 via these interfaces.
+endef
+
+CONFIGURE_ARGS += \
+       --without-gnutls \
+       --without-libnettle \
+       --without-libgmp \
+       --without-libgcrypt \
+       --with-openssl \
+       --without-sqlite3 \
+       --with-libxml2 \
+       --without-libexpat \
+       --without-libcares \
+       --with-libz
+
+CONFIGURE_VARS += \
+       ZLIB_CFLAGS="-I$(STAGING_DIR)/usr/include" \
+       ZLIB_LIBS="-L$(STAGING_DIR)/usr/lib"
+
+define Package/aria2/install
+       $(INSTALL_DIR) $(1)/usr/bin/
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/aria2c $(1)/usr/bin/
+endef
+
+$(eval $(call BuildPackage,aria2))