kismet: fix compilation with libcxx 10 12386/head
authorRosen Penev <rosenp@gmail.com>
Tue, 2 Jun 2020 23:25:43 +0000 (16:25 -0700)
committerRosen Penev <rosenp@gmail.com>
Tue, 2 Jun 2020 23:25:43 +0000 (16:25 -0700)
Seems a bind call is missing.

Signed-off-by: Rosen Penev <rosenp@gmail.com>
net/kismet/Makefile
net/kismet/patches/030-libcxx.patch

index d61e4a2974203a921ac2398f70c38c579a9f6e0b..baacf6e4683d5a69cf485b55835de8568564c5dc 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=kismet
 PKG_VERSION:=2016-07-R1
-PKG_RELEASE:=3
+PKG_RELEASE:=4
 
 PKG_LICENSE:=LGPLv2.1
 PKG_CPE_ID:=cpe:/a:kismet:kismet
index 128a9d191da9007b5c7ad070ad541f00b9c38a55..9f0a9966475d7d4ef297bedebdb42c25e1bf7c7d 100644 (file)
@@ -1,3 +1,14 @@
+--- a/ipc_remote.cc
++++ b/ipc_remote.cc
+@@ -914,7 +914,7 @@ int RootIPCRemote::OpenFDPassSock() {
+                       return -1;
+               }
+-              if (bind(ipc_fd_fd, (const struct sockaddr *) &unixsock, sizeof(unixsock))) {
++              if (::bind(ipc_fd_fd, (const struct sockaddr *) &unixsock, sizeof(unixsock))) {
+                       close(ipc_fd_fd);
+                       _MSG("Failed to bind socket to pass file descriptors: " + 
+                                string(strerror(errno)), MSGFLAG_ERROR);
 --- a/packetsource_wext.cc
 +++ b/packetsource_wext.cc
 @@ -405,7 +405,7 @@ void PacketSource_Wext::OpenWpaSupplicant() {