ar71xx: Add "info" partition for TP-Link Archer C7 v5
authorAdrian Schmutzler <freifunk@adrianschmutzler.de>
Thu, 4 Apr 2019 12:16:19 +0000 (14:16 +0200)
committerPetr Štetiar <ynezz@true.cz>
Thu, 11 Apr 2019 20:54:45 +0000 (22:54 +0200)
This adds the "info" MTD partition, as it is specified in the
ath79 DTS:
https://github.com/openwrt/openwrt/blob/master/target/linux/ath79/dts/qca9563_tplink_archer-c7-v5.dts#L35

This is required to set the WAN MAC address, as it is build based
on the LAN MAC address, which in turn has to be read from the
"info" partition:
https://github.com/openwrt/openwrt/blob/master/target/linux/ath79/dts/qca9563_tplink_archer-x7-v5.dtsi#L184

Backport of commit 9aa8f87d277bf2f666fa5bf90c5efd59dd044d54

Tested-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
target/linux/ar71xx/image/generic-tp-link.mk

index 86d1aa41e3b2af9e5af56b6e33ea6af5863b986f..c2062c8511efaa9bb4ae8a025c15d1bddd64b69b 100644 (file)
@@ -147,7 +147,7 @@ define Device/archer-c7-v5
   BOARDNAME := ARCHER-C7-V5
   TPLINK_BOARD_ID := ARCHER-C7-V5
   IMAGE_SIZE := 15104k
-  MTDPARTS := spi0.0:128k(factory-uboot)ro,128k(u-boot)ro,64k@0x50000(art)ro,1536k@0xc0000(kernel),13824k(rootfs),15360k@0xc0000(firmware)
+  MTDPARTS := spi0.0:128k(factory-uboot)ro,128k(u-boot)ro,64k@0x50000(art)ro,128k@0x60000(info)ro,1536k@0xc0000(kernel),13824k(rootfs),15360k@0xc0000(firmware)
   SUPPORTED_DEVICES := archer-c7-v5
 endef
 TARGET_DEVICES += archer-c7-v5