syslog-ng: stop service when uninstalling/updating 6847/head
authorPhilip Prindeville <philipp@redfish-solutions.com>
Wed, 22 Aug 2018 23:13:20 +0000 (17:13 -0600)
committerPhilip Prindeville <philipp@redfish-solutions.com>
Sat, 20 Oct 2018 19:39:45 +0000 (13:39 -0600)
This avoids the possibility of the service getting reloaded and
a previously running instance trying to re-dynamically link to
more modern plugins.

Signed-off-by: Philip Prindeville <philipp@redfish-solutions.com>
admin/syslog-ng/Makefile

index 948983416ad678dcd0b161841730fab8381a987b..c1990ba3ac09c671fbced929dacbe0cdb4f0df00 100644 (file)
@@ -2,7 +2,7 @@ include  $(TOPDIR)/rules.mk
 
 PKG_NAME:=syslog-ng
 PKG_VERSION:=3.17.2
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_MAINTAINER:=W. Michael Petullo <mike@flyn.org>
 
@@ -74,4 +74,19 @@ define Package/syslog-ng/install
        $(call libtool_remove_files,$(1))
 endef
 
+define Package/syslog-ng/prerm
+       #!/bin/sh
+       # check if we are on real system
+       if [ -z "$${IPKG_INSTROOT}" ]; then
+               # wish we had pidof unconditionally
+               pid=$(ps | grep syslog | grep -v grep | awk '{ print $$1; }')
+               [ -n "$$pid" ] && /etc/init.d/syslog-ng stop
+               [ "$${PKG_UPGRADE}" != "1" ] && {
+                       echo "Removing rc.d symlink for syslog-ng"
+                       /etc/init.d/syslog-ng disable
+               }
+       fi
+       exit 0
+endef
+
 $(eval $(call BuildPackage,syslog-ng))