icecast: Fix configure if both vorbis and tremor host packages installed
authorTed Hess <thess@kitschensync.net>
Thu, 19 Jan 2017 20:33:07 +0000 (15:33 -0500)
committerTed Hess <thess@kitschensync.net>
Thu, 19 Jan 2017 20:34:13 +0000 (15:34 -0500)
Signed-off-by: Ted Hess <thess@kitschensync.net>
multimedia/icecast/Makefile
multimedia/icecast/patches/001-icecast-2.4.0-tremor.patch

index 97c5bd7aa88d5cc168ea587daa31f96c967f67e8..2ef95b78137fd9f32c59f450846f7bbfdc089f05 100644 (file)
@@ -55,6 +55,12 @@ CONFIGURE_ARGS+= \
        --with-xslt-config="$(STAGING_DIR)/usr/bin/xslt-config"
 
 
+# Manually edit configure in case both vorbis and tremor host packages are installed
+define Build/Configure
+       $(SED) 's,-lvorbis -lm,-lvorbisidec -logg ,g' $(PKG_BUILD_DIR)/configure
+       $(call Build/Configure/Default)
+endef
+
 define Package/icecast/install
        $(INSTALL_DIR) $(1)/etc
        $(CP) $(PKG_INSTALL_DIR)/etc/icecast.xml $(1)/etc/
index 7fd9d52babef15dc01ede43b07c9a5dcb864ad25..49861d2e3eaecce8e82578c8fa19292a1f087ac1 100644 (file)
@@ -21,7 +21,7 @@
      return NULL;
  }
  
-+/* Some additional functions from vorbis missing from tremore */
++/* Some additional functions from vorbis missing from tremor */
 +
 +static void _v_writestring(oggpack_buffer *o,char *s, int bytes)
 +{