packages/portmap: use new service functions
authorNicolas Thill <nico@openwrt.org>
Sun, 13 Nov 2011 22:15:53 +0000 (22:15 +0000)
committerNicolas Thill <nico@openwrt.org>
Sun, 13 Nov 2011 22:15:53 +0000 (22:15 +0000)
SVN-Revision: 29063

net/portmap/Makefile
net/portmap/files/portmap.init

index 19c373d6d78888f81e693951e565f75a857dee66..70499aa0b84a716072a55f13de82fcee438d49f7 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006-2010 OpenWrt.org
+# Copyright (C) 2006-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=portmap
 PKG_VERSION:=6.0
-PKG_RELEASE:=2
+PKG_RELEASE:=3
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tgz
 PKG_SOURCE_URL:=http://neil.brown.name/portmap/
index fd7322cf730cfff83318108d837640f6a39685d7..e73701c8e275be34afa8b28f540e9086cb619f84 100644 (file)
@@ -1,18 +1,13 @@
 #!/bin/sh /etc/rc.common
-# Copyright (C) 2006-2008 OpenWrt.org
+# Copyright (C) 2006-2011 OpenWrt.org
 
 START=19
 STOP=19
 
-NAME=portmap
-PROG=/usr/sbin/$NAME
-DEFAULT=/etc/default/$NAME
-
 start() {
-       [ -f $DEFAULT ] && . $DEFAULT
-       start-stop-daemon -q -S -x $PROG -- $OPTIONS
+       service_start /usr/sbin/portmap
 }
 
 stop() {
-       start-stop-daemon -q -K -x $PROG -- $OPTIONS
+       service_stop /usr/sbin/portmap
 }