[packages] net/freeswitch: Re-added per-package module configurartion (currently...
authorDaniel Dickinson <crazycshore@gmail.com>
Sun, 22 Aug 2010 05:06:49 +0000 (05:06 +0000)
committerDaniel Dickinson <crazycshore@gmail.com>
Sun, 22 Aug 2010 05:06:49 +0000 (05:06 +0000)
SVN-Revision: 22755

net/freeswitch/Makefile

index 13a0d6d043c7363b78ffe13e2169e68370c69a30..b6d36b5ce3563c4632ea07f844e85151f86d2470 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=freeswitch
 PKG_VERSION:=1.0.6
-PKG_RELEASE:=7
+PKG_RELEASE:=8
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
@@ -467,6 +467,22 @@ define BuildPlugin
                        $(PKG_INSTALL_DIR)/usr/lib/freeswitch/$$$$$$$${f}.so \
                        $$(1)/usr/lib/freeswitch/ ; \
        done
+       if [ -d "./files/etc.packages/$(1)" ]; then \
+               $(INSTALL_DIR) $$(1)/etc/freeswitch ; \
+               $(CP) \
+                       ./files/etc.packages/$(1)/* \
+                       $$(1)/etc/freeswitch/ ; \
+        fi
+  endef
+
+  define Package/freeswitch-mod-$(1)/postinst
+#!/bin/sh
+sed -i -e 's|^\([ \t]*\)<!-- *\(.*\)"mod_$(1)"\(.*\) *-->\(.*\)$$$$|\1\2"mod_$(1)"\3\4|' $$$${IPKG_INSTROOT}/etc/freeswitch/autoload_configs/modules.conf.xml
+  endef
+
+  define Package/freeswitch-mod-$(1)/postrm
+#!/bin/sh
+sed -i -e 's|^\([ \t]*\)\(.*\)"mod_$(1)"\(.*\)$$$$|\1<!-- \2"mod_$(1)"\3 -->|' $$$${IPKG_INSTROOT}/etc/freeswitch/autoload_configs/modules.conf.xml
   endef
 
   $$(eval $$(call BuildPackage,freeswitch-mod-$(1)))