[packages] apcupsd: Move local include path before all other includes paths.
authorLars-Peter Clausen <lars@metafoo.de>
Sat, 20 Feb 2010 21:36:16 +0000 (21:36 +0000)
committerLars-Peter Clausen <lars@metafoo.de>
Sat, 20 Feb 2010 21:36:16 +0000 (21:36 +0000)
Otherwise it will include the wrong md5.h and the build will fail. Fixes #5449

SVN-Revision: 19784

net/apcupsd/Makefile
net/apcupsd/patches/010-fix-include-paths.patch [new file with mode: 0644]

index ae32e2591f0e3b457a56278769bc546e0fef4092..9ce3cd8d4aa393dc220eddf14d92e934a4f19cd9 100644 (file)
@@ -31,6 +31,7 @@ define Build/Configure
                --with-distname=unknown \
                --sysconfdir=/etc/apcupsd \
                --enable-usb \
+               --without-x \
        )
 endef
 
diff --git a/net/apcupsd/patches/010-fix-include-paths.patch b/net/apcupsd/patches/010-fix-include-paths.patch
new file mode 100644 (file)
index 0000000..2151544
--- /dev/null
@@ -0,0 +1,13 @@
+diff --git a/autoconf/variables.mak.in b/autoconf/variables.mak.in
+index b67e467..6022434 100644
+--- a/autoconf/variables.mak.in
++++ b/autoconf/variables.mak.in
+@@ -65,7 +65,7 @@ DRVLIBS = @PTHREAD_LFLAGS@ @DRVLIBS@
+ X_LIBS = @X_LIBS@
+ X_EXTRA_LIBS = @X_EXTRA_LIBS@
+-CPPFLAGS = @CPPFLAGS@ -I$(topdir)/include $(EXTRAINCS)
++CPPFLAGS = -I$(topdir)/include @CPPFLAGS@ $(EXTRAINCS)
+ CFLAGS = $(CPPFLAGS) @CFLAGS@ @PTHREAD_CFLAGS@
+ CXXFLAGS = $(CPPFLAGS) @CXXFLAGS@ @PTHREAD_CFLAGS@
+ LDFLAGS = @LDFLAGS@