python: change $(STAGING_DIR)/host to $(STAGING_DIR_HOST) 2596/head
authorAlexandru Ardelean <ardeleanalex@gmail.com>
Thu, 14 Apr 2016 08:54:40 +0000 (11:54 +0300)
committerAlexandru Ardelean <ardeleanalex@gmail.com>
Thu, 14 Apr 2016 08:56:21 +0000 (11:56 +0300)
It seems that this can become an issue.
Found when building python3-setuptools from packages/trunk
in openwrt/15.05.

python3-setuptools is not in packages/for-15.05

Signed-off-by: Alexandru Ardelean <ardeleanalex@gmail.com>
20 files changed:
lang/python/Makefile
lang/python/files/python-host.mk
lang/python/files/python-package-codecs.mk
lang/python/files/python-package-compiler.mk
lang/python/files/python-package-ctypes.mk
lang/python/files/python-package-db.mk
lang/python/files/python-package-decimal.mk
lang/python/files/python-package-dev.mk
lang/python/files/python-package-distutils.mk
lang/python/files/python-package-email.mk
lang/python/files/python-package-gdbm.mk
lang/python/files/python-package-lib2to3.mk
lang/python/files/python-package-logging.mk
lang/python/files/python-package-multiprocessing.mk
lang/python/files/python-package-ncurses.mk
lang/python/files/python-package-openssl.mk
lang/python/files/python-package-pydoc.mk
lang/python/files/python-package-sqlite3.mk
lang/python/files/python-package-unittest.mk
lang/python/files/python-package-xml.mk

index 63af64de5b5abfeb6de53583dbbf4d6e28860dc2..56e271618153c1f047aecb3718456f7360140e17 100644 (file)
@@ -12,7 +12,7 @@ include ./files/python-package.mk
 
 PKG_NAME:=python
 PKG_VERSION:=$(PYTHON_VERSION).$(PYTHON_VERSION_MICRO)
-PKG_RELEASE:=6
+PKG_RELEASE:=7
 
 PKG_SOURCE:=Python-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=https://www.python.org/ftp/python/$(PKG_VERSION)
@@ -144,13 +144,13 @@ define Build/InstallDev
                $(PKG_INSTALL_DIR)/usr/include/python$(PYTHON_VERSION) \
                $(1)/usr/include/
        $(CP) \
-               $(STAGING_DIR)/host/lib/python$(PYTHON_VERSION) \
+               $(STAGING_DIR_HOST)/lib/python$(PYTHON_VERSION) \
                $(PKG_INSTALL_DIR)/usr/lib/libpython$(PYTHON_VERSION).so* \
                $(1)/usr/lib/
        $(CP) \
-               $(STAGING_DIR)/host/lib/pkgconfig/python.pc \
-               $(STAGING_DIR)/host/lib/pkgconfig/python2.pc \
-               $(STAGING_DIR)/host/lib/pkgconfig/python-$(PYTHON_VERSION).pc \
+               $(STAGING_DIR_HOST)/lib/pkgconfig/python.pc \
+               $(STAGING_DIR_HOST)/lib/pkgconfig/python2.pc \
+               $(STAGING_DIR_HOST)/lib/pkgconfig/python-$(PYTHON_VERSION).pc \
                $(1)/usr/lib/pkgconfig
        $(CP) \
                $(PKG_INSTALL_DIR)/usr/lib/python$(PYTHON_VERSION)/config \
@@ -221,16 +221,16 @@ HOST_CONFIGURE_ARGS+= \
        --without-cxx-main \
        --without-pymalloc \
        --with-threads \
-       --with-system-expat=$(STAGING_DIR)/host \
-       --with-system-ffi="$(STAGING_DIR)/host" \
+       --with-system-expat="$(STAGING_DIR_HOST)" \
+       --with-system-ffi="$(STAGING_DIR_HOST)" \
        --with-ensurepip=upgrade \
        CONFIG_SITE= \
        CFLAGS="$(HOST_CFLAGS)"
 
 define Host/Install
-       $(INSTALL_DIR) $(STAGING_DIR)/host/bin/
+       $(INSTALL_DIR) $(STAGING_DIR_HOST)/bin/
        $(MAKE) -C $(HOST_BUILD_DIR) install
-       $(INSTALL_BIN) $(HOST_BUILD_DIR)/Parser/pgen $(STAGING_DIR)/host/bin/pgen2
+       $(INSTALL_BIN) $(HOST_BUILD_DIR)/Parser/pgen $(STAGING_DIR_HOST)/bin/pgen2
 endef
 
 $(eval $(call HostBuild))
index 8736d29ad27123b795ac65379e735122a574d189..671189c32e01a171e1e6abc759e54f06c0b5e827 100644 (file)
@@ -1,11 +1,11 @@
 #
-# Copyright (C) 2015-2016 OpenWrt.org
+# Copyright (C) 2016-2016 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
 
-HOST_PYTHON_DIR:=$(STAGING_DIR)/host
+HOST_PYTHON_DIR:=$(STAGING_DIR_HOST)
 HOST_PYTHON_INC_DIR:=$(HOST_PYTHON_DIR)/include/python$(PYTHON_VERSION)
 HOST_PYTHON_LIB_DIR:=$(HOST_PYTHON_DIR)/lib/python$(PYTHON_VERSION)
 
@@ -13,7 +13,7 @@ HOST_PYTHON_PKG_DIR:=/lib/python$(PYTHON_VERSION)/site-packages
 
 HOST_PYTHON_BIN:=$(HOST_PYTHON_DIR)/bin/python$(PYTHON_VERSION)
 
-HOST_PYTHONPATH:=$(HOST_PYTHON_LIB_DIR):$(STAGING_DIR)/host/$(HOST_PYTHON_PKG_DIR)
+HOST_PYTHONPATH:=$(HOST_PYTHON_LIB_DIR):$(STAGING_DIR_HOST)/$(HOST_PYTHON_PKG_DIR)
 
 define HostPython
        if [ "$(strip $(3))" == "HOST" ]; then \
@@ -44,7 +44,7 @@ define Build/Compile/HostPyMod
                LDSHARED="$(HOSTCC) -shared" \
                CFLAGS="$(HOST_CFLAGS)" \
                CPPFLAGS="$(HOST_CPPFLAGS) -I$(HOST_PYTHON_INC_DIR)" \
-               LDFLAGS="$(HOST_LDFLAGS) -lpython$(PYTHON_VERSION) -Wl$(comma)-rpath=$(STAGING_DIR)/host/lib" \
+               LDFLAGS="$(HOST_LDFLAGS) -lpython$(PYTHON_VERSION) -Wl$(comma)-rpath=$(STAGING_DIR_HOST)/lib" \
                _PYTHON_HOST_PLATFORM=linux2 \
                $(3) \
                , \
index d6e183500e9df4757df561687b32eb3c6627c8a6..7d3c615f3298a810a30101aa279350f7c9521fd6 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006-2015 OpenWrt.org
+# Copyright (C) 2006-2016 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
index fbe8bf2e60a874c614dbdf7d3e087b9782aa0faf..c840ce103e8539b1e9e108c5dc8a6fadbb4f2285 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006-2015 OpenWrt.org
+# Copyright (C) 2006-2016 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
index 66b303310667ce15a5e90cf42f88f385cedf5431..5c34b7a7c3007618317dad4ac0945b2330f8cf73 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006-2015 OpenWrt.org
+# Copyright (C) 2006-2016 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
index 26f35d882d891955a7f8c0fce2e1fbdb3eed9d83..a257820a3d33dd12945721bd3653417524ee008b 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006-2015 OpenWrt.org
+# Copyright (C) 2006-2016 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
index 33e3a21d235ac1f04f326bf43f4c0683c843fac0..578486d8682720c9739ebf099113472399df64c3 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006-2015 OpenWrt.org
+# Copyright (C) 2006-2016 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
index 2f807b2830d41c0d78e93b479230765e04c0084b..6a2b942f4f252b99e4dd5f021b932465a069a589 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006-2015 OpenWrt.org
+# Copyright (C) 2006-2016 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
index f5119fac36bf75b5f3de0261af280f271f94807e..a139ddba07fc5c84ec64debf93a0716e145167f6 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006-2015 OpenWrt.org
+# Copyright (C) 2006-2016 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
index 51fa8d12a0992e77a0af2f0041dbdf7c0b8aa2b9..8c15583dc61e2854e648abe273efa6d9d5c28e39 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006-2015 OpenWrt.org
+# Copyright (C) 2006-2016 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
index 8e0b16f9cab19004e6a80d4864001575f0fe61bf..23c7a293cdc75b425dadeea14dd0f6d4a9ae4490 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006-2015 OpenWrt.org
+# Copyright (C) 2006-2016 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
index 5d6942d65d0084438d271c4f6ac974756d032849..925cfe20419d254fc124199d70109f903c0608ad 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006-2015 OpenWrt.org
+# Copyright (C) 2006-2016 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
index f45de35dc0b6e14c5e697d93cb1c6269db5ef834..efef5314a877fdb52a140a790b6499e7e533daf3 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006-2015 OpenWrt.org
+# Copyright (C) 2006-2016 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
index 2a9f5b185a3e68bdae8140d4adaec77a3aeef8e8..ccb55f59b7995c25e0cb24a7fe0ee1f0a52a1797 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006-2015 OpenWrt.org
+# Copyright (C) 2006-2016 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
index bab9415593a866edfdc08b2f6749173da31080db..d952b5034f651f5ac860376ec3878e0c250a7bd2 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006-2015 OpenWrt.org
+# Copyright (C) 2006-2016 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
index 4d897eb81227d7dd7afe2af2cb1c85f538cfdb42..dbf6fe18073108424e0fe5ad0e356219db42af38 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006-2015 OpenWrt.org
+# Copyright (C) 2006-2016 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
index ca27f9b36b45c0464d489fbfedef0fbb077f0df7..1e3c38529649036e2d99b369fea8b12c97beb465 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006-2015 OpenWrt.org
+# Copyright (C) 2006-2016 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
index c5abb122e738a715f4e71237f55fe901cebe5e22..22a6fbcd268358416e92c599fde6c2906faf50c4 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006-2015 OpenWrt.org
+# Copyright (C) 2006-2016 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
index 6e1ab552d8c57fe2adfaf1ec60218bf9c296f9f2..3c93f5136dbfd9262d90cef604f70a5839970743 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006-2015 OpenWrt.org
+# Copyright (C) 2006-2016 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
index bb82f0170833baa6e2d0abfbe6fb33d40c4843d7..28e734ea4def74db01d9e4bd5e3864a2863420fd 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006-2015 OpenWrt.org
+# Copyright (C) 2006-2016 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.