[packages] less: fix clash with Busybox (#11042)
authorJo-Philipp Wich <jow@openwrt.org>
Sat, 25 Feb 2012 14:54:58 +0000 (14:54 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Sat, 25 Feb 2012 14:54:58 +0000 (14:54 +0000)
SVN-Revision: 30720

utils/less/Makefile

index 79abf542361c27055b992f46dc14c6f33a69c6ec..82e01054c191234492e69baba28534aaec46161a 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2010 OpenWrt.org
+# Copyright (C) 2010-2012 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=less
 PKG_VERSION:=436
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://www.greenwoodsoftware.com/less
@@ -30,8 +30,20 @@ define Package/less/description
 endef
 
 define Package/less/install
-        $(INSTALL_DIR) $(1)/usr/bin
-       $(CP) $(PKG_BUILD_DIR)/less $(1)/usr/bin/less
+       $(INSTALL_DIR) $(1)/bin
+       $(CP) $(PKG_BUILD_DIR)/less $(1)/bin/less
+endef
+
+define Package/less/postinst
+#!/bin/sh
+[ -L "$${IPKG_INSTROOT}/usr/bin/less" ] && rm -f "$${IPKG_INSTROOT}/usr/bin/less"
+exit 0
+endef
+
+define Package/less/postrm
+#!/bin/sh
+/bin/busybox less -h 2>&1 | grep -q BusyBox && ln -sf ../../bin/busybox /usr/bin/less
+exit 0
 endef
 
 $(eval $(call BuildPackage,less))