packages/pcsc-lite: use new service functions
authorNicolas Thill <nico@openwrt.org>
Fri, 11 Nov 2011 15:46:25 +0000 (15:46 +0000)
committerNicolas Thill <nico@openwrt.org>
Fri, 11 Nov 2011 15:46:25 +0000 (15:46 +0000)
SVN-Revision: 28944

utils/pcsc-lite/Makefile
utils/pcsc-lite/files/pcscd.init

index f8c434c3397f29babf9142e68bec07a826778a06..ad0b9b5061b1dc5781659b38a1d59745aae3eb9f 100644 (file)
@@ -1,8 +1,15 @@
+#
+# Copyright (C) 2009-2011 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=pcsc-lite
 PKG_VERSION:=1.5.5
-PKG_RELEASE:=3
+PKG_RELEASE:=4
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=http://alioth.debian.org/frs/download.php/3082
index cd9ea27f2f9976b65d3bfec550851d0988d3345c..9a7a9057c6783a8ea273d1d5b774e0838cc34bad 100644 (file)
@@ -1,11 +1,14 @@
 #!/bin/sh /etc/rc.common
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2009-2011 OpenWrt.org
+
 START=50
 
+SERVICE_PID_FILE=/var/run/pcscd/pcscd.pid
+
 start() {
-       pcscd
+       service_start /usr/sbin/pcscd
 }
 
 stop() {
-       killall pcscd
+       service_stop /usr/sbin/pcscd
 }