boost: move the + to the right place to fix build errors
authorFelix Fietkau <nbd@openwrt.org>
Mon, 24 Sep 2012 17:32:13 +0000 (17:32 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Mon, 24 Sep 2012 17:32:13 +0000 (17:32 +0000)
SVN-Revision: 33533

libs/boost/Makefile

index 211816781eec3b7ac5b8f928b6a14b76b9ce27dd..d2826b32cc54163808d9e614ecaff97c6e47f874 100644 (file)
@@ -184,13 +184,13 @@ CONFIGURE_PREFIX:=$(PKG_INSTALL_DIR)
 TARGET_LDFLAGS += -pthread -lrt
 
 define Build/Compile
-       ( cd $(PKG_BUILD_DIR) ; \
+       +( cd $(PKG_BUILD_DIR) ; \
                echo "using gcc : $(ARCH) : $(GNU_TARGET_NAME)-gcc : <compileflags>\"$(TARGET_CFLAGS)\" <cxxflags>\"$(TARGET_CXXFLAGS)\" <linkflags>\"$(TARGET_LDFLAGS)\" ;" > tools/build/v2/user-config.jam ; \
                $(if $(CONFIG_PACKAGE_boost-python), \
                        echo "using python : : $(STAGING_DIR_ROOT)/usr/bin/python :     $(STAGING_DIR)/usr/include/python2.7/ ;" >> \
                                tools/build/v2/user-config.jam; \
                ) \
-               +bjam \
+               bjam \
                        '-sBUILD=release <optimization>space <inlining>on <debug-symbols>off' \
                        $(filter -j%,$(PKG_JOBS)) \
                        --toolset=gcc-$(ARCH) --build-type=minimal --layout=system \