libinput: update to version 1.7.3 and use libudev-fbsd
authorDaniel Golle <daniel@makrotopia.org>
Sun, 18 Jun 2017 21:20:59 +0000 (23:20 +0200)
committerDaniel Golle <daniel@makrotopia.org>
Sun, 18 Jun 2017 23:33:32 +0000 (01:33 +0200)
Signed-off-by: Daniel Golle <daniel@makrotopia.org>
libs/libinput/Makefile
libs/libinput/patches/001-no-locale.patch
libs/libinput/patches/002-static_assert.patch

index 988488bb415a1c054193ae0c951ce31d7453d11b..a90d13c575045dd8bad8aa146b3e22deb7123902 100644 (file)
@@ -1,6 +1,3 @@
-#
-# Copyright (C) 2007-2015 OpenWrt.org
-#
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
@@ -8,12 +5,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=libinput
-PKG_VERSION:=1.3.1
+PKG_VERSION:=1.7.3
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=http://www.freedesktop.org/software/libinput/
-PKG_MD5SUM:=458fc483f7227d3c4c330f4abd6dfa77
+PKG_HASH:=096d612d2711f0caa2de544976ff3729e6233511ab373808644cc2dd5affcb1d
 
 PKG_LICENSE:=MIT
 PKG_LICENSE_FILES:=COPYING
@@ -33,7 +30,7 @@ define Package/libinput
   CATEGORY:=Libraries
   TITLE:=a library to handle input devices
   URL:=http://freedesktop.org/wiki/Software/libinput/
-  DEPENDS:=+libevdev +mtdev +libudev
+  DEPENDS:=+libevdev +mtdev +libudev-fbsd
 endef
 
 define Package/libinput/description
index 8f5c5a1cacf33716f8f9df2b6b9704eba67f4ae7..adf9abeb80cfa129ed38b7dbf766dbb5a3c3608f 100644 (file)
@@ -1,22 +1,38 @@
 --- a/src/libinput-util.c
 +++ b/src/libinput-util.c
-@@ -216,18 +216,10 @@ parse_mouse_wheel_click_angle_property(c
- double
- parse_trackpoint_accel_property(const char *prop)
+@@ -31,7 +31,6 @@
+ #include "config.h"
+ #include <ctype.h>
+-#include <locale.h>
+ #include <stdarg.h>
+ #include <stdbool.h>
+ #include <stdio.h>
+--- a/src/libinput-util.h
++++ b/src/libinput-util.h
+@@ -30,7 +30,6 @@
+ #include <assert.h>
+ #include <errno.h>
+ #include <limits.h>
+-#include <locale.h>
+ #include <math.h>
+ #include <stdarg.h>
+ #include <stdbool.h>
+@@ -448,16 +447,8 @@ safe_atod(const char *str, double *val)
  {
+       char *endptr;
+       double v;
 -      locale_t c_locale;
-       double accel;
-       char *endp;
  
 -      /* Create a "C" locale to force strtod to use '.' as separator */
 -      c_locale = newlocale(LC_NUMERIC_MASK, "C", (locale_t)0);
 -      if (c_locale == (locale_t)0)
--              return 0.0;
--
--      accel = strtod_l(prop, &endp, c_locale);
+-              return false;
 -
+-      errno = 0;
+-      v = strtod_l(str, &endptr, c_locale);
 -      freelocale(c_locale);
-+      accel = strtod(prop, &endp);
-       if (*endp != '\0')
-               return 0.0;
++      v = strtod(str, &endptr);
+       if (errno > 0)
+               return false;
+       if (str == endptr)
index e5aaee26faa5e0a49c03d953d350129fb4fbc8dc..e5b12448eb044e9f89a965098c4899c2e46caba0 100644 (file)
@@ -1,6 +1,6 @@
 --- a/src/evdev-tablet.c
 +++ b/src/evdev-tablet.c
-@@ -1155,9 +1155,11 @@ static void
+@@ -1204,9 +1204,11 @@ static void
  tablet_mark_all_axes_changed(struct tablet_dispatch *tablet,
                             struct libinput_tablet_tool *tool)
  {