cyrus-sasl: fix compile bug, so that we do not need this ugly workaround introduced...
authorHauke Mehrtens <hauke@hauke-m.de>
Sun, 10 Apr 2011 11:45:15 +0000 (11:45 +0000)
committerHauke Mehrtens <hauke@hauke-m.de>
Sun, 10 Apr 2011 11:45:15 +0000 (11:45 +0000)
SVN-Revision: 26575

libs/cyrus-sasl/Makefile
libs/cyrus-sasl/patches/100-fix-compile.patch [new file with mode: 0644]

index 2aa86f143ef91a99c4a68550628080998dd7bd91..980cc75f8726e7375a71121cd92e2a7622867b1b 100644 (file)
@@ -68,7 +68,8 @@ CONFIGURE_ARGS += \
        --without-sqlite \
        --without-rc4 \
        --without-dmalloc \
-       --without-sfio
+       --without-sfio \
+       --disable-sample
 
 define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR)/include \
@@ -77,9 +78,6 @@ define Build/Compile
                CFLAGS="" \
                CPPFLAGS="" \
                makemd5
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-               DESTDIR="$(PKG_INSTALL_DIR)" \
-               all install || \
        $(MAKE) -C $(PKG_BUILD_DIR) \
                DESTDIR="$(PKG_INSTALL_DIR)" \
                all install
diff --git a/libs/cyrus-sasl/patches/100-fix-compile.patch b/libs/cyrus-sasl/patches/100-fix-compile.patch
new file mode 100644 (file)
index 0000000..eaefcd1
--- /dev/null
@@ -0,0 +1,19 @@
+--- a/lib/Makefile.in
++++ b/lib/Makefile.in
+@@ -176,6 +176,7 @@ SASL_KRB_LIB = @SASL_KRB_LIB@
+ SASL_MECHS = @SASL_MECHS@
+ SASL_STATIC_LIBS = @SASL_STATIC_LIBS@
+ SASL_STATIC_OBJS = @SASL_STATIC_OBJS@
++SASL_STATIC_SRC = $(patsubst %.o, %.c, $(SASL_STATIC_OBJS))
+ SASL_STATIC_SRCS = @SASL_STATIC_SRCS@
+ SASL_UTIL_HEADERS_EXTRA = @SASL_UTIL_HEADERS_EXTRA@
+ SASL_UTIL_LIBS_EXTRA = @SASL_UTIL_LIBS_EXTRA@
+@@ -646,7 +647,7 @@ libsasl2.a: libsasl2.la $(SASL_STATIC_OB
+       rm -f $@
+       ln -s .libs/$@ $@
+-$(SASL_STATIC_OBJS): linksrcs
++$(SASL_STATIC_SRC): linksrcs
+ linksrcs:
+       -ln -s $(SASL_STATIC_SRCS) .