AA: packages: samba36: fix segmentation fault when trying to add non-existent users
authorJonas Gorski <jogo@openwrt.org>
Mon, 25 Feb 2013 12:45:52 +0000 (12:45 +0000)
committerJonas Gorski <jogo@openwrt.org>
Mon, 25 Feb 2013 12:45:52 +0000 (12:45 +0000)
Backport of r35610.

Signed-off-by: Jonas Gorski <jogo@openwrt.org>
SVN-Revision: 35772

net/samba36/Makefile
net/samba36/patches/111-owrt_smbpasswd.patch

index 2a6b6b69719a325b9d714e2de069a779b4f8d7fc..f519a21018e1532b97b00a617ec68174ce48d844 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=samba
 PKG_VERSION:=3.6.5
-PKG_RELEASE:=2
+PKG_RELEASE:=3
 
 PKG_SOURCE_URL:=http://ftp.samba.org/pub/samba \
        http://ftp.samba.org/pub/samba/old-versions
index d8089a34ec3616bd3a6c078b9e6a65e67724f551..aebe0953bfac8cfa65e2b216df4759358af1b710 100644 (file)
 +      }
 +
 +      if (!find_passwd_line(fp, user, &p1)) {
-+              printf("User %s not found or invalid in /etc/passwd\n");
++              printf("User %s not found or invalid in /etc/passwd\n", user);
 +              goto out;
 +      }
 +