zerotier: update to 1.14.0
authorMoritz Warning <moritzwarning@web.de>
Mon, 6 May 2024 20:50:36 +0000 (22:50 +0200)
committerRosen Penev <rosenp@gmail.com>
Wed, 8 May 2024 00:42:05 +0000 (17:42 -0700)
Includes refreshed patches.

Signed-off-by: Moritz Warning <moritzwarning@web.de>
net/zerotier/Makefile
net/zerotier/patches/0001-fix-miniupnpc-natpmp-include-paths.patch
net/zerotier/patches/0002-remove-PIE-options.patch
net/zerotier/patches/0003-fix-compilation-for-arm_cortex-a7-neon.patch
net/zerotier/patches/0004-add-missing-libatomic.patch
net/zerotier/patches/0005-remove-noexecstack.patch

index e9c1426a14600c48614b0d24e44b4ff3976c0961..6d38423f91cbdcf0bfe3763225115aeab42f5911 100644 (file)
@@ -6,12 +6,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=zerotier
-PKG_VERSION:=1.12.2
-PKG_RELEASE:=2
+PKG_VERSION:=1.14.0
+PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=https://codeload.github.com/zerotier/ZeroTierOne/tar.gz/$(PKG_VERSION)?
-PKG_HASH:=7c6512cfc208374ea9dc9931110e35f71800c34890e0f35991ea485aae66e31c
+PKG_HASH:=7191623a81b0d1b552b9431e8864dd3420783ee518394ac1376cee6aaf033291
 PKG_BUILD_DIR:=$(BUILD_DIR)/ZeroTierOne-$(PKG_VERSION)
 
 PKG_MAINTAINER:=Moritz Warning <moritzwarning@web.de>
index 8779829f4413f0d2c84d3dd64bbf43fa182f6551..a4a129ae3c2f418a19ebb1d1cde34b66547228b1 100644 (file)
@@ -1,6 +1,6 @@
-From 8b30e8617720c2a540c84c5c00508e8081e9f06e Mon Sep 17 00:00:00 2001
+From f53004bd22365900a1dbb120dae62ce8b614d31d Mon Sep 17 00:00:00 2001
 From: Moritz Warning <moritzwarning@web.de>
-Date: Sun, 27 Aug 2023 23:26:33 +0200
+Date: Mon, 6 May 2024 22:31:57 +0200
 Subject: [PATCH 1/5] fix miniupnpc/natpmp include paths
 
 Signed-off-by: Moritz Warning <moritzwarning@web.de>
@@ -10,7 +10,7 @@ Signed-off-by: Moritz Warning <moritzwarning@web.de>
 
 --- a/make-linux.mk
 +++ b/make-linux.mk
-@@ -25,8 +25,8 @@ TIMESTAMP=$(shell date +"%Y%m%d%H%M")
+@@ -26,8 +26,8 @@ TIMESTAMP=$(shell date +"%Y%m%d%H%M")
  # otherwise build into binary as done on Mac and Windows.
  ONE_OBJS+=osdep/PortMapper.o
  override DEFS+=-DZT_USE_MINIUPNPC
@@ -21,7 +21,7 @@ Signed-off-by: Moritz Warning <moritzwarning@web.de>
  ifeq ($(MINIUPNPC_IS_NEW_ENOUGH),1)
        override DEFS+=-DZT_USE_SYSTEM_MINIUPNPC
        LDLIBS+=-lminiupnpc
-@@ -34,7 +34,7 @@ else
+@@ -35,7 +35,7 @@ else
        override DEFS+=-DMINIUPNP_STATICLIB -DMINIUPNPC_SET_SOCKET_TIMEOUT -DMINIUPNPC_GET_SRC_ADDR -D_BSD_SOURCE -D_DEFAULT_SOURCE -D_XOPEN_SOURCE=600 -DOS_STRING="\"Linux\"" -DMINIUPNPC_VERSION_STRING="\"2.0\"" -DUPNP_VERSION_STRING="\"UPnP/1.1\"" -DENABLE_STRNATPMPERR
        ONE_OBJS+=ext/miniupnpc/connecthostport.o ext/miniupnpc/igd_desc_parse.o ext/miniupnpc/minisoap.o ext/miniupnpc/minissdpc.o ext/miniupnpc/miniupnpc.o ext/miniupnpc/miniwget.o ext/miniupnpc/minixml.o ext/miniupnpc/portlistingparse.o ext/miniupnpc/receivedata.o ext/miniupnpc/upnpcommands.o ext/miniupnpc/upnpdev.o ext/miniupnpc/upnperrors.o ext/miniupnpc/upnpreplyparse.o
  endif
index 0b21991eb9864ce8d4177242c01c0b7a2c20bbc9..4e44f2ef4523ac588e1a7f49dfbd1879a40175a5 100644 (file)
@@ -1,6 +1,6 @@
-From 9b97099560a79529f2b5a748e73164ae038d2b76 Mon Sep 17 00:00:00 2001
+From c10b5ed4c6c44e36178b0a5a82da9e8eaa957008 Mon Sep 17 00:00:00 2001
 From: Moritz Warning <moritzwarning@web.de>
-Date: Sun, 27 Aug 2023 23:27:33 +0200
+Date: Mon, 6 May 2024 22:34:15 +0200
 Subject: [PATCH 2/5] remove PIE options
 
 Signed-off-by: Moritz Warning <moritzwarning@web.de>
@@ -10,16 +10,16 @@ Signed-off-by: Moritz Warning <moritzwarning@web.de>
 
 --- a/make-linux.mk
 +++ b/make-linux.mk
-@@ -70,7 +70,7 @@ else
+@@ -71,7 +71,7 @@ else
        override CFLAGS+=-Wall -Wno-deprecated -pthread $(INCLUDES) -DNDEBUG $(DEFS)
        CXXFLAGS?=-O3 -fstack-protector
        override CXXFLAGS+=-Wall -Wno-deprecated -std=c++17 -pthread $(INCLUDES) -DNDEBUG $(DEFS)
 -      LDFLAGS=-pie -Wl,-z,relro,-z,now
 +      LDFLAGS=-Wl,-z,relro,-z,now
-       RUSTFLAGS=--release
+       ZT_CARGO_FLAGS=--release
  endif
  
-@@ -327,7 +327,7 @@ ifeq ($(ZT_CONTROLLER),1)
+@@ -333,7 +333,7 @@ ifeq ($(ZT_CONTROLLER),1)
  endif
  
  # ARM32 hell -- use conservative CFLAGS
@@ -28,7 +28,7 @@ Signed-off-by: Moritz Warning <moritzwarning@web.de>
        ifeq ($(shell if [ -e /usr/bin/dpkg ]; then dpkg --print-architecture; fi),armel)
                override CFLAGS+=-march=armv5t -mfloat-abi=soft -msoft-float -mno-unaligned-access -marm
                override CXXFLAGS+=-march=armv5t -mfloat-abi=soft -msoft-float -mno-unaligned-access -marm
-@@ -354,8 +354,8 @@ ifeq ($(ZT_USE_ARM32_NEON_ASM_CRYPTO),1)
+@@ -360,8 +360,8 @@ ifeq ($(ZT_USE_ARM32_NEON_ASM_CRYPTO),1)
  endif
  
  # Position Independence
index 8831edef7b32b0a8996420e4d4c2988b7d87c99e..34b336196b731bb1f704d4fb448dfa759351e03d 100644 (file)
@@ -1,4 +1,4 @@
-From 1689085363cf87deb3877139931a8a88d8c7bcd3 Mon Sep 17 00:00:00 2001
+From fee674d5a5c7cc847d7e1925ddf41eea89d915c4 Mon Sep 17 00:00:00 2001
 From: Moritz Warning <moritzwarning@web.de>
 Date: Mon, 4 Jul 2022 00:10:52 +0200
 Subject: [PATCH 3/5] fix compilation for arm_cortex-a7+neon
index d8d9c617321f9f53b2a048a2c5cd3fef97f2e761..5b7cb80c284671346537df332ba69f3724873e64 100644 (file)
@@ -1,6 +1,6 @@
-From b3879d721734862aa64433f7faf124a0862da029 Mon Sep 17 00:00:00 2001
+From f8b4c4a045a9711c316a5c48b238c24cc0948da1 Mon Sep 17 00:00:00 2001
 From: Moritz Warning <moritzwarning@web.de>
-Date: Sun, 27 Aug 2023 22:27:12 +0200
+Date: Mon, 6 May 2024 22:35:41 +0200
 Subject: [PATCH 4/5] add missing libatomic
 
 Signed-off-by: Moritz Warning <moritzwarning@web.de>
@@ -12,10 +12,10 @@ Signed-off-by: Moritz Warning <moritzwarning@web.de>
 +++ b/make-linux.mk
 @@ -11,7 +11,7 @@ endif
  
- INCLUDES?=-Izeroidc/target -isystem ext -Iext/prometheus-cpp-lite-1.0/core/include -Iext-prometheus-cpp-lite-1.0/3rdparty/http-client-lite/include -Iext/prometheus-cpp-lite-1.0/simpleapi/include
+ INCLUDES?=-Irustybits/target -isystem ext -Iext/prometheus-cpp-lite-1.0/core/include -Iext-prometheus-cpp-lite-1.0/3rdparty/http-client-lite/include -Iext/prometheus-cpp-lite-1.0/simpleapi/include
  DEFS?=
 -LDLIBS?=
 +LDLIBS?=-latomic
  DESTDIR?=
+ EXTRA_DEPS?=
  
- include objects.mk
index 07b1ac3b4cbee49a4d382131f7c5b87b39aa9598..8569fa8e8b975516c00e8b13264e94be70508588 100644 (file)
@@ -1,4 +1,4 @@
-From adcc68c6c3de8460bd6263d3478873953a4cf894 Mon Sep 17 00:00:00 2001
+From 2a5a279ac0192bc444cd1c3059169f576817d8b9 Mon Sep 17 00:00:00 2001
 From: Moritz Warning <moritzwarning@web.de>
 Date: Mon, 28 Aug 2023 09:48:28 +0200
 Subject: [PATCH 5/5] remove noexecstack
@@ -10,7 +10,7 @@ The compilers for arm_cortex-a9 do not recognize this argument.
 
 --- a/make-linux.mk
 +++ b/make-linux.mk
-@@ -358,7 +358,7 @@ endif
+@@ -364,7 +364,7 @@ endif
  #override CXXFLAGS+=-fPIC -fPIE
  
  # Non-executable stack