bluez: fix compilation with GCC14
authorRosen Penev <rosenp@gmail.com>
Mon, 13 May 2024 22:46:53 +0000 (15:46 -0700)
committerRosen Penev <rosenp@gmail.com>
Tue, 14 May 2024 23:39:18 +0000 (16:39 -0700)
Remove _GNU_SOURCE to avoid redefinition warning.

Signed-off-by: Rosen Penev <rosenp@gmail.com>
utils/bluez/Makefile
utils/bluez/patches/207-gcc14.patch [new file with mode: 0644]

index e1299edda1fdd33aa721b1a7655e06e641243c71..ea54420a94ddc9241575ac89a5dc6aed2e4e6fa6 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=bluez
 PKG_VERSION:=5.72
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=@KERNEL/linux/bluetooth/
@@ -80,8 +80,6 @@ define Package/bluez-daemon/conffiles
 /etc/config/bluetooth
 endef
 
-TARGET_CFLAGS += -D_GNU_SOURCE
-
 CONFIGURE_ARGS += \
        --enable-static \
        --enable-client \
diff --git a/utils/bluez/patches/207-gcc14.patch b/utils/bluez/patches/207-gcc14.patch
new file mode 100644 (file)
index 0000000..f2ef1e4
--- /dev/null
@@ -0,0 +1,35 @@
+--- a/tools/hex2hcd.c
++++ b/tools/hex2hcd.c
+@@ -24,6 +24,7 @@
+ #include <stdlib.h>
+ #include <stdbool.h>
+ #include <sys/stat.h>
++#include <libgen.h>
+ static ssize_t process_record(int fd, const char *line, uint16_t *upper_addr)
+ {
+@@ -289,6 +290,7 @@ static void ver_parse_entry(const char *
+ {
+       struct stat st;
+       int fd;
++      char *pncopy = strdup(pathname);
+       fd = open(pathname, O_RDONLY);
+       if (fd < 0) {
+@@ -302,7 +304,7 @@ static void ver_parse_entry(const char *
+       }
+       if (S_ISREG(st.st_mode)) {
+-              ver_parse_file(basename(pathname));
++              ver_parse_file(basename(pncopy));
+               goto done;
+       }
+@@ -329,6 +331,7 @@ static void ver_parse_entry(const char *
+ done:
+       close(fd);
++      free(pncopy);
+ }
+ static void ver_print_table(int argc, char *argv[])