freeswitch: fix compilation with musl 1.2.0 580/head
authorRosen Penev <rosenp@gmail.com>
Fri, 9 Oct 2020 09:26:49 +0000 (02:26 -0700)
committerRosen Penev <rosenp@gmail.com>
Mon, 12 Oct 2020 01:53:57 +0000 (18:53 -0700)
Signed-off-by: Rosen Penev <rosenp@gmail.com>
net/freeswitch/Makefile
net/freeswitch/patches/420-time.patch [new file with mode: 0644]

index 29f38bffb3a5ab506d910d305975b2ad79399d79..9885df0d8e98e3fc0e91e8520166f2850b2b9963 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=freeswitch
 PKG_VERSION:=1.10.5
-PKG_RELEASE:=2
+PKG_RELEASE:=3
 PKG_MAINTAINER:=Sebastian Kemper <sebastian_ml@gmx.net>
 
 PKG_SOURCE:=freeswitch-$(PKG_VERSION).-release.tar.xz
diff --git a/net/freeswitch/patches/420-time.patch b/net/freeswitch/patches/420-time.patch
new file mode 100644 (file)
index 0000000..17d05bb
--- /dev/null
@@ -0,0 +1,16 @@
+--- a/src/include/switch_platform.h
++++ b/src/include/switch_platform.h
+@@ -270,9 +270,13 @@ typedef intptr_t switch_ssize_t;
+ #if defined(__FreeBSD__) && SIZEOF_VOIDP == 4
+ #define TIME_T_FMT "d"
+ #else
++#if __USE_TIME_BITS64
++#define TIME_T_FMT SWITCH_INT64_T_FMT
++#else
+ #define TIME_T_FMT "ld"
+ #endif
+ #endif
++#endif
+ #if UINTPTR_MAX == 0xffffffffffffffff