add a patch to fix lcd4linux on linux 2.6.19 (see [6052]), add some touches to preven...
authorNicolas Thill <nico@openwrt.org>
Wed, 10 Jan 2007 00:24:06 +0000 (00:24 +0000)
committerNicolas Thill <nico@openwrt.org>
Wed, 10 Jan 2007 00:24:06 +0000 (00:24 +0000)
SVN-Revision: 6054

utils/lcd4linux/Makefile
utils/lcd4linux/patches/130-linux_2.6.19_wireless_h.patch [new file with mode: 0644]

index 264c3856abb5ce11d8f45d4f7c40e16175a445d0..c343eefaaf27c760a7aa4d2d3bb13357203e408a 100644 (file)
@@ -33,10 +33,17 @@ define Package/lcd4linux
   URL:=http://lcd4linux.bulix.org/
 endef
 
-# commas are interpreted by the $(call ...) macro, so define a intermediate variable holding our drivers spec
+# commas are interpreted by the $(call ...) macro, so define an intermediate variable holding our drivers spec
 PKG_CONFIGURE_DRIVERS:=all,!PNG,!RouterBoard,!X11
 
 define Build/Configure
+        (cd $(PKG_BUILD_DIR); touch \
+               configure.in \
+               aclocal.m4 \
+               Makefile.in \
+               config-h.in \
+               configure \
+       );
        $(call Build/Configure/Default, \
                --without-x \
                --with-drivers="$(PKG_CONFIGURE_DRIVERS)" \
diff --git a/utils/lcd4linux/patches/130-linux_2.6.19_wireless_h.patch b/utils/lcd4linux/patches/130-linux_2.6.19_wireless_h.patch
new file mode 100644 (file)
index 0000000..9f7957b
--- /dev/null
@@ -0,0 +1,15 @@
+diff -ruN lcd4linux-0.10.0+cvs20051015-old/plugin_wireless.c lcd4linux-0.10.0+cvs20051015-new/plugin_wireless.c
+--- lcd4linux-0.10.0+cvs20051015-old/plugin_wireless.c 2005-05-08 06:32:45.000000000 +0200
++++ lcd4linux-0.10.0+cvs20051015-new/plugin_wireless.c 2007-01-10 01:08:13.000000000 +0100
+@@ -92,6 +92,11 @@
+ #include <sys/ioctl.h>
+ #include <net/if_arp.h>
++#include <linux/version.h>
++#if LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,19)
++#include <linux/types.h>
++#include <linux/if.h>
++#endif
+ #include <linux/wireless.h>
+ #include <math.h>