mvebu: add sysupgrade image for TP-Link OC200
authorStijn Tintel <stijn@linux-ipv6.be>
Tue, 22 Sep 2020 01:16:52 +0000 (04:16 +0300)
committerStijn Tintel <stijn@linux-ipv6.be>
Wed, 8 Nov 2023 12:00:41 +0000 (14:00 +0200)
This image can be written to the NAND flash with dd:

dd if=/tmp/openwrt-mvebu-cortexa53-tplink_oc200-squashfs-sysupgrade.bin of=/dev/mmcblk0 bs=512 seek=896

target/linux/mvebu/image/cortexa53.mk

index 62842cbf15e8c13ebd8012e8d533406691503f4d..550940828d2d011309e68641356a9c04b5c11203 100644 (file)
@@ -111,11 +111,14 @@ define Device/tplink_oc200
   FILESYSTEMS := squashfs
   KERNEL := kernel-bin
   KERNEL_INITRAMFS := kernel-bin | append-dtb
-  #KERNEL_INITRAMFS := kernel-bin | append-dtb | uImage none
   KERNEL_LOADADDR := 0x5000000
   KERNEL_NAME := Image
-  IMAGES := factory.bin
+  IMAGES := factory.bin sysupgrade.bin
   IMAGE/factory.bin := append-rootfs | tplink-mvebu
+  IMAGE/sysupgrade.bin := append-dtb | pad-to 64k | check-size 64k | \
+       append-kernel | pad-to 32832k | check-size 32832k | \
+       append-rootfs | pad-rootfs $$(BLOCKSIZE) | check-size 295424k | \
+       append-metadata
   TPLINK_BOARD_ID := OC200
 endef
 TARGET_DEVICES += tplink_oc200